aboutsummaryrefslogtreecommitdiff
path: root/mail/ezmlm-web
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-09 19:04:59 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-09 19:04:59 +0000
commit5d20bc51087e290e2dd050adebae018836bf803a (patch)
tree0a112357b591054b4db8d0bd73b4ff6e7e7e2098 /mail/ezmlm-web
parent7b2d813540d3846eed3f840489a10c2dc8697293 (diff)
downloadports-5d20bc51087e290e2dd050adebae018836bf803a.tar.gz
ports-5d20bc51087e290e2dd050adebae018836bf803a.zip
Notes
Diffstat (limited to 'mail/ezmlm-web')
-rw-r--r--mail/ezmlm-web/Makefile43
-rw-r--r--mail/ezmlm-web/distinfo1
-rw-r--r--mail/ezmlm-web/files/patch-aa35
-rw-r--r--mail/ezmlm-web/pkg-comment1
-rw-r--r--mail/ezmlm-web/pkg-descr5
-rw-r--r--mail/ezmlm-web/pkg-message13
-rw-r--r--mail/ezmlm-web/pkg-plist9
7 files changed, 107 insertions, 0 deletions
diff --git a/mail/ezmlm-web/Makefile b/mail/ezmlm-web/Makefile
new file mode 100644
index 000000000000..f1e4c9fd32a1
--- /dev/null
+++ b/mail/ezmlm-web/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ezmlm-web
+# Date Created: 18 May 2000
+# Whom: Guy Antony Halse <guy@rucus.ru.za.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ezmlm-web
+PORTVERSION= 2.0
+CATEGORIES= mail www
+MASTER_SITES= ftp://rucus.ru.ac.za/pub/mail/ezmlm/
+
+MAINTAINER= guy-ezmlm@rucus.ru.ac.za
+
+BUILD_DEPENDS= ${EZMLM_DIR}/bin/ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Ezmlm.pm:${PORTSDIR}/mail/p5-Mail-Ezmlm
+RUN_DEPENDS= ${LOCALBASE}/sbin/apache:${PORTSDIR}/www/apache13 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
+
+CGI_BIN?= /share/apache/cgi-bin/
+EZMLM_DIR?= /
+
+USE_PERL5= YES
+PLIST_SUB= CGI_BIN=${CGI_BIN:S/\///} EZMLM_DIR=${EZMLM_DIR:S/\///}
+
+do-build:
+ @cd ${WRKSRC}; ${MAKE} index; ${MV} index ezmlm-web
+
+do-install:
+ ${MKDIR} ${LOCALBASE}${CGI_BIN} ${LOCALBASE}${EZMLM_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/ezmlm-web.cgi ${LOCALBASE}${EZMLM_DIR}/bin
+ ${INSTALL_DATA} ${WRKSRC}/ezmlmwebrc ${LOCALBASE}${EZMLM_DIR}/etc/ezmlm
+ ${INSTALL_PROGRAM} -o alias -g qmail -m 4755 ${WRKSRC}/ezmlm-web ${LOCALBASE}${CGI_BIN}
+ ${MKDIR} ${PREFIX}/share/ezmlm-web
+.for file in CHANGES README index.c htaccess.sample webusers.sample
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/share/ezmlm-web
+.endfor
+
+post-install:
+ @${SED} s!%%PREFIX%%!${PREFIX}!g ${PKGDIR}/MESSAGE
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/mail/ezmlm-web/distinfo b/mail/ezmlm-web/distinfo
new file mode 100644
index 000000000000..44320c16e0bf
--- /dev/null
+++ b/mail/ezmlm-web/distinfo
@@ -0,0 +1 @@
+MD5 (ezmlm-web-2.0.tar.gz) = 749a164c260f80857574f4dc1c0bb226
diff --git a/mail/ezmlm-web/files/patch-aa b/mail/ezmlm-web/files/patch-aa
new file mode 100644
index 000000000000..8135b9e8bd5a
--- /dev/null
+++ b/mail/ezmlm-web/files/patch-aa
@@ -0,0 +1,35 @@
+--- ezmlm-web.cgi.orig Sat Jan 29 13:36:02 2000
++++ ezmlm-web.cgi Thu May 18 13:43:27 2000
+@@ -1,4 +1,10 @@
+ #!/usr/bin/perl -wT
++
++#
++# MODIFIED FOR FREEBSD PORTS
++# Guy Antony Halse <guy@rucus.ru.ac.za>
++#
++
+ #===========================================================================
+ # ezmlm-web.cgi - version 2.0 - 29/01/2000
+ # $Id: ezmlm-web.cgi,v 1.1 2000/01/29 11:35:40 guy Exp $
+@@ -76,8 +82,8 @@
+ require "$opt_C"; # Command Line
+ } elsif(-e "$HOME_DIR/.ezmlmwebrc") {
+ require "$HOME_DIR/.ezmlmwebrc"; # User
+-} elsif(-e "/etc/ezmlm/ezmlmwebrc") {
+- require "/etc/ezmlm/ezmlmwebrc"; # System
++} elsif(-e "/usr/local/etc/ezmlm/ezmlmwebrc") {
++ require "/usr/local/etc/ezmlm/ezmlmwebrc"; # System
+ } elsif(-e "./ezmlmwebrc") {
+ require "./ezmlmwebrc"; # Install
+ } else {
+@@ -604,8 +610,8 @@
+ my ($qmail, $listname, $options, $i);
+
+ # Some taint checking ...
+- $qmail = $1 if $q->param('inlocal') =~ /-?([\w.+:]+)$/;
+- $listname = $q->param('list'); $listname =~ s/ /_/; # In case some git tries to put a space in the file name
++ $qmail = $1 if $q->param('inlocal') =~ /(?:$USER-)?([^\<\>\\\/\s]+)$/;
++ $listname = $q->param('list'); $listname =~ s/ /_/g; # In case some git tries to put a space in the file name
+
+ # Sanity Checks ...
+ return 1 if ($listname eq '' || $qmail eq '');
diff --git a/mail/ezmlm-web/pkg-comment b/mail/ezmlm-web/pkg-comment
new file mode 100644
index 000000000000..a2f859e14a20
--- /dev/null
+++ b/mail/ezmlm-web/pkg-comment
@@ -0,0 +1 @@
+CGI script that lets you manage ezmlm-idx mailing lists through the web
diff --git a/mail/ezmlm-web/pkg-descr b/mail/ezmlm-web/pkg-descr
new file mode 100644
index 000000000000..b801368a2476
--- /dev/null
+++ b/mail/ezmlm-web/pkg-descr
@@ -0,0 +1,5 @@
+ezmlm-web provides a convinient, GUI method for users to configure and
+maintain ezmlm-idx mailing lists. It allows one to create, reconfigure and
+delete mailing lists, as well as manage subscriber lists. It supports all
+the features of ezmlm-idx 4.0, and has full support for virtual domains,
+multiple access levels. It can also be configured to use different languages.
diff --git a/mail/ezmlm-web/pkg-message b/mail/ezmlm-web/pkg-message
new file mode 100644
index 000000000000..b26c64ba35a6
--- /dev/null
+++ b/mail/ezmlm-web/pkg-message
@@ -0,0 +1,13 @@
+
+NB!! By default no security is enabled on ezmlm-web.
+
+The effectively means that at the moment, anyone can go to
+ http://<your host>/cgi-bin/ezmlm-web
+and alter any of your primary mailing lists.
+
+If this is not what you want (and it probably isn't :), you need to
+either create a <File> directive in you apache configuration, or
+use a .htaccess file, or provide some other means of security.
+
+Have a look at the README file in %%PREFIX%%/share/ezmlm-web for
+more information. There are also some sample files there.
diff --git a/mail/ezmlm-web/pkg-plist b/mail/ezmlm-web/pkg-plist
new file mode 100644
index 000000000000..87f10b4c4fbb
--- /dev/null
+++ b/mail/ezmlm-web/pkg-plist
@@ -0,0 +1,9 @@
+share/ezmlm-web/CHANGES
+share/ezmlm-web/README
+share/ezmlm-web/index.c
+share/ezmlm-web/htaccess.sample
+share/ezmlm-web/webusers.sample
+@dirrm share/ezmlm-web
+%%EZMLM_DIR%%/bin/ezmlm-web.cgi
+%%EZMLM_DIR%%/etc/ezmlm/ezmlmwebrc
+%%CGI_BIN%%/ezmlm-web