aboutsummaryrefslogtreecommitdiff
path: root/mail/faces
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-01-11 14:58:17 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-01-11 14:58:17 +0000
commitb190bd047571e6431fc1cccc827c0808fbb89019 (patch)
tree04bdd8b186a29ba8a8f30df2e334ce5fa7d927f8 /mail/faces
parenta5612de6506641038ef74bd172856fb1ed550321 (diff)
downloadports-b190bd047571e6431fc1cccc827c0808fbb89019.tar.gz
ports-b190bd047571e6431fc1cccc827c0808fbb89019.zip
Notes
Diffstat (limited to 'mail/faces')
-rw-r--r--mail/faces/Makefile63
-rw-r--r--mail/faces/files/patch-configure21
2 files changed, 54 insertions, 30 deletions
diff --git a/mail/faces/Makefile b/mail/faces/Makefile
index 13ca51815a7e..e22cf7b0e7f4 100644
--- a/mail/faces/Makefile
+++ b/mail/faces/Makefile
@@ -3,15 +3,21 @@
PORTNAME= faces
PORTVERSION= 1.7.7
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= mail
MASTER_SITES= SF
MAINTAINER= ashish@FreeBSD.org
COMMENT= Visual mail, user, and print face server
-OPTIONS_DEFINE= X11 NAS RPLAY SOX DOCS NLS
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS_DEFINE= X11 DOCS NLS AUDIO
OPTIONS_DEFAULT= X11
+OPTIONS_SINGLE= AUDIO
+OPTIONS_SINGLE_AUDIO= NAS RPLAY SOX
+AUDIO_DESC= Audio support
X11_DESC= X11/GTK support
RPLAY_DESC= rplay audio support
SOX_DESC= Sox audio support
@@ -19,36 +25,33 @@ SOX_DESC= Sox audio support
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-USE_LDCONFIG= yes
+OPTIONS_SUB= X11
-PORTDOCS= README
+X11_USE= GNOME=gtk12
+X11_CPPFLAGS= -I../compface -I${LOCALBASE}/include
+X11_LDFLAGS= -L../compface -L${LOCALBASE}/lib
+X11_CONFIGURE_ARGS= --enable-imap --enable-pop \
+ --enable-name-unknown --with-spooldir=/var/mail \
+ --with-facedir=${DATADIR}
+X11_CONFIGURE_WITH= x
-.include <bsd.port.options.mk>
+AUDIO_CONFIGURE_ENABLE= audio
+
+NAS_CONFIGURE_ON= --with-audio-cmd=${LOCALBASE}/bin/auplay
+NAS_RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
+
+SOX_CONFIGURE_ON= --with-audio-cmd=${LOCALBASE}/bin/play
+SOX_RUN_DEPENDS= play:${PORTSDIR}/audio/sox
+
+RPLAY_CONFIGURE_ON= --with-audio-cmd=${LOCALBASE}/bin/rplay
+RPLAY_RUN_DEPENDS= rplay:${PORTSDIR}/audio/rplay
-.if ! ${PORT_OPTIONS:MX11}
-PLIST_SUB+= X11="@comment "
-WITH_AUDIO= # none
-.else # with X11
-PLIST_SUB+= X11=""
-USE_GNOME= gtk12
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I../compface -I${LOCALBASE}/include
-LDFLAGS+= -L../compface -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --enable-imap --enable-pop \
- --enable-name-unknown --with-spooldir=/var/mail \
- --with-facedir=${DATADIR}
-.endif
-.ifdef WITH_NAS
- CONFIGURE_ARGS+= --enable-audio --with-audio-cmd=${LOCALBASE}/bin/auplay
- RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
-.elifdef WITH_SOX
- CONFIGURE_ARGS+= --enable-audio --with-audio-cmd=${LOCALBASE}/bin/play
- RUN_DEPENDS= play:${PORTSDIR}/audio/sox
-.elifdef WITH_RPLAY
- CONFIGURE_ARGS+= --enable-audio --with-audio-cmd=${LOCALBASE}/bin/rplay
- RUN_DEPENDS= rplay:${PORTSDIR}/audio/rplay
-.endif
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
# I have no better idea up to now
# Install the working Makefile for compface from the old faces port
@@ -57,11 +60,11 @@ post-patch:
@${REINPLACE_CMD} -e "s%/usr/local/faces%${DATADIR}%g ; \
s%/var/spool/mail%/var/mail%g" ${WRKSRC}/faces/faces.man
@${LN} -sf ${WRKSRC}/faces/faces.man ${WRKSRC}/faces/faces.1
-.ifdef WITH_NAS
+.if ${PORT_OPTIONS:MNAS}
@${REINPLACE_CMD} -e "s%rplay%auplay%" ${WRKSRC}/faces/Faces.ad
-.elifdef WITH_SOX
+.elif ${PORT_OPTIONS:MSOX}
@${REINPLACE_CMD} -e "s%rplay%play%" ${WRKSRC}/faces/Faces.ad
-.elifdef WITH_RPLAY
+.elif ${PORT_OPTIONS:MRPLAY}
# nada
.else
@${REINPLACE_CMD} -e "s%^faces.audioSupport.*%faces.audioSupport: false%" ${WRKSRC}/faces/Faces.ad
diff --git a/mail/faces/files/patch-configure b/mail/faces/files/patch-configure
new file mode 100644
index 000000000000..3c689d076be6
--- /dev/null
+++ b/mail/faces/files/patch-configure
@@ -0,0 +1,21 @@
+$FreeBSD$
+
+--- configure.orig 2015-01-11 20:18:10.319363623 +0530
++++ configure 2015-01-11 20:21:02.304351633 +0530
+@@ -5065,6 +5065,8 @@
+ fi
+ done
+
++if test "x$have_x" = xyes; then
++
+ # Check whether --with-gtk-prefix or --without-gtk-prefix was given.
+ if test "${with_gtk_prefix+set}" = set; then
+ withval="$with_gtk_prefix"
+@@ -5356,6 +5358,7 @@
+ fi
+
+ rm -f conf.gtktest
++fi # have_x=xyes
+
+ ALL_LINGUAS=""
+ echo "$as_me:5361: checking for $CC option to accept ANSI C" >&5