aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail/Makefile
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-04-28 17:26:35 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-04-28 17:26:35 +0000
commiteaf628233775993bb2876c585b5420b0ba1bcd56 (patch)
tree09666ceb8d395c7022dbea624d471ff5a323a5ba /mail/fetchmail/Makefile
parent16a81bf7dbfa4d2e96a7d1c6e1d157c4fcd94372 (diff)
Notes
Diffstat (limited to 'mail/fetchmail/Makefile')
-rw-r--r--mail/fetchmail/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index b6c6de4895f3..3a556e82c09e 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,7 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= http://www.catb.org/~esr/%SUBDIR%/ \
ftp://ftp.ayamura.org/pub/%SUBDIR%/ \
@@ -26,17 +26,20 @@ COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/APOP/KPOP/ETRN/ODMR
RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
+.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+.endif
.if defined(WITH_X11)
USE_PYTHON= yes
.endif
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-POP2 --enable-SDPS \
- --enable-nls --with-hesiod=no --enable-fallback=no
+ --with-hesiod=no --enable-fallback=no
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
@@ -46,6 +49,14 @@ FDOC= ${PREFIX}/share/doc/fetchmail
DOCS= FAQ FEATURES NEWS NOTES README \
design-notes.html fetchmail-FAQ.html fetchmail-features.html
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400014