aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-04 10:47:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-04 10:47:33 +0000
commita3a756d06e1955074943d687d69227b17520d67f (patch)
treefe7f4598833e4d94c67d422c7d24012bbd16e264 /mail/fetchmail/Makefile
parent621547fb62ea54c69581a77475baddcd4ba0099d (diff)
downloadports-a3a756d06e1955074943d687d69227b17520d67f.tar.gz
ports-a3a756d06e1955074943d687d69227b17520d67f.zip
Notes
Diffstat (limited to 'mail/fetchmail/Makefile')
-rw-r--r--mail/fetchmail/Makefile53
1 files changed, 14 insertions, 39 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index b9c497a97431..f423bdffdda5 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -10,8 +10,7 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
-PORTVERSION= 6.3.11
-PORTREVISION= 1
+PORTVERSION= 6.3.13
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://homepages.uni-paderborn.de/mandree/fetchmail/:ma \
@@ -33,6 +32,7 @@ SUB_FILES= pkg-message
USE_BZIP2= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
@@ -46,8 +46,7 @@ MLINKS= fetchmail.1 fetchmailconf.1
OPTIONS= X11 "Python/Tkinter dependencies for fetchmailconf" off \
NLS "National language support (NLS)." on \
NTLM "Build in support for NTLM/MSN authentication." off \
- POP2 "Build pop2 support (obsolete)." off \
- GSSAPI "Build GSSAPI support (requires KRB5_HOME to be set)" off
+ GSSAPI "Build GSSAPI/Kerberos 5 support" off
.include <bsd.port.options.mk>
@@ -78,20 +77,22 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
-CONFIGURE_ARGS += --with-kerberos5=${KRB5_HOME}
-
-.if defined(WITH_GSSAPI)
-CONFIGURE_ARGS+=--with-gssapi=${KRB5_HOME}
+.if !defined(KRB5_HOME)
+.if exists(${LOCALBASE}/lib/libkrb5.a)
+KRB5_HOME= ${LOCALBASE}
+.elif exists(/usr/lib/libkrb5.a)
+KRB5_HOME= /usr
+.endif
.endif
-.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4)
-CONFIGURE_ARGS += --with-kerberos=/usr
+.if defined(KRB5_HOME) && !exists(${KRB5_HOME}/lib/libkrb5.a)
+BROKEN= KRB5_HOME is set but doesn't provide lib/libkrb5.a
+.endif
.if defined(WITH_GSSAPI)
-CONFIGURE_ARGS+=--with-gssapi=/usr
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
+CONFIGURE_ARGS += --with-gssapi=${KRB5_HOME}
.endif
-
.endif
.if defined(WITH_NTLM)
@@ -109,32 +110,6 @@ pre-patch:
@${REINPLACE_CMD} -e "s,@LOCALBASE@,${LOCALBASE},g" \
${WRKDIR}/fetchmailconf
-pre-configure:
-
- @${ECHO_CMD} ""
-
-.if defined(KRB5_HOME)
- @${ECHO_CMD} "Using Kerberos V support in ${KRB5_HOME}."
-.else
- @${ECHO_CMD} "Use KRB5_HOME=<directory> to enable Kerberos V support in <directory> (usually /usr)."
-.endif
-
-.if defined(WITH_GSSAPI)
-.if defined(KRB5_HOME)
- @${ECHO_CMD} "Enabling GSSAPI support in ${KRB5_HOME}."
-.elif defined(MAKE_KERBEROS4)
-.if exists(/usr/lib/libkrb.a)
- @${ECHO_CMD} "Enabling GSSAPI support in /usr."
-.else
- @${ECHO_CMD} "Unable to detect Kerberos in your system. Disabling GSSAPI support."
-.endif
-.else
- @${ECHO_CMD} "GSSAPI requires Kerberos, but Kerberos is disabled."
-.endif
-.endif
-
- @${ECHO_CMD} ""
-
pre-su-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL