aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2007-09-03 19:22:28 +0000
committerSimon Barner <barner@FreeBSD.org>2007-09-03 19:22:28 +0000
commit3017d8ada21e245b3dc3a4a7139b49697b37bb97 (patch)
treeba0ff2fcce86e4824cbf882350f64dfeeb3ff9af /mail/fetchmail
parent3c005206b96b4e08de4d42fe3abd7146454e0b23 (diff)
downloadports-3017d8ada21e245b3dc3a4a7139b49697b37bb97.tar.gz
ports-3017d8ada21e245b3dc3a4a7139b49697b37bb97.zip
Notes
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile7
-rw-r--r--mail/fetchmail/files/patch-CVE-2007-456511
2 files changed, 15 insertions, 3 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 172e14087a17..2dc072cf3894 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,7 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
${MASTER_SITE_SUNSITE:S/$/:sunsite/}\
@@ -51,13 +51,14 @@ OPTIONS= X11 "Python/Tkinter dependencies for fetchmailconf" off \
POP2 "Build pop2 support (obsolete)." off \
GSSAPI "Build GSSAPI support (requires KRB5_HOME to be set)" off
+.include <bsd.port.pre.mk>
+
.if defined(WITH_X11)
USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
RUN_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
-.include <bsd.port.pre.mk>
-
# Pop2 is obsolete
.if defined(WITH_POP2)
CONFIGURE_ARGS+=--enable-POP2
diff --git a/mail/fetchmail/files/patch-CVE-2007-4565 b/mail/fetchmail/files/patch-CVE-2007-4565
new file mode 100644
index 000000000000..77783efde9af
--- /dev/null
+++ b/mail/fetchmail/files/patch-CVE-2007-4565
@@ -0,0 +1,11 @@
+--- sink.c (revision 5118)
++++ sink.c (revision 5119)
+@@ -262,7 +262,7 @@
+ const char *md1 = "MAILER-DAEMON", *md2 = "MAILER-DAEMON@";
+
+ /* don't bounce in reply to undeliverable bounces */
+- if (!msg->return_path[0] ||
++ if (!msg || !msg->return_path[0] ||
+ strcmp(msg->return_path, "<>") == 0 ||
+ strcasecmp(msg->return_path, md1) == 0 ||
+ strncasecmp(msg->return_path, md2, strlen(md2)) == 0)