aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2006-01-30 12:47:53 +0000
committerSimon Barner <barner@FreeBSD.org>2006-01-30 12:47:53 +0000
commit3cd0edaa2b97b94847ba38dda9edd5ca32a40bea (patch)
treef7fe697d8c5c22bba89c8076bc16694b97fb17e8 /mail/fetchmail
parent3b5981766e7591ca8ca771a550f72b08ec2c621a (diff)
downloadports-3cd0edaa2b97b94847ba38dda9edd5ca32a40bea.tar.gz
ports-3cd0edaa2b97b94847ba38dda9edd5ca32a40bea.zip
Notes
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile1
-rw-r--r--mail/fetchmail/files/patch-netrc.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index f7ab00898608..7db854466351 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,6 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.2
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
diff --git a/mail/fetchmail/files/patch-netrc.c b/mail/fetchmail/files/patch-netrc.c
new file mode 100644
index 000000000000..fcd9bafc4f21
--- /dev/null
+++ b/mail/fetchmail/files/patch-netrc.c
@@ -0,0 +1,15 @@
+--- netrc.c (Revision 4683)
++++ netrc.c (Revision 4684)
+@@ -314,8 +314,10 @@
+ free_netrc(netrc_entry *a) {
+ while(a) {
+ netrc_entry *n = a->next;
+- memset(a->password, 0x55, strlen(a->password));
+- xfree(a->password);
++ if (a->password != NULL) {
++ memset(a->password, 0x55, strlen(a->password));
++ free(a->password);
++ }
+ xfree(a->login);
+ xfree(a->host);
+ xfree(a);