aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-15 23:02:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-15 23:02:52 +0000
commitd0ff441f6cb6739f8a6195c9c3cadaaccdd089b4 (patch)
tree34aef0c56cfc1dd76a5add5d08d9a711690ba72c /mail/fetchmail
parent36e406eb3b4f487ffde2fc97ce97e12ea3870d1a (diff)
downloadports-d0ff441f6cb6739f8a6195c9c3cadaaccdd089b4.tar.gz
ports-d0ff441f6cb6739f8a6195c9c3cadaaccdd089b4.zip
Notes
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile12
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-Makefile.in11
-rw-r--r--mail/fetchmail/files/patch-fetchlimit-exitstatus18
-rw-r--r--mail/fetchmail/pkg-plist1
5 files changed, 10 insertions, 38 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index e37006b8eeef..b949eaa4c903 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -10,10 +10,11 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
-PORTVERSION= 6.3.9
+PORTVERSION= 6.3.10
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://homepages.uni-paderborn.de/mandree/fetchmail/:ma \
+ http://mandree.home.pages.de/fetchmail/:ma \
${MASTER_SITE_SUNSITE:S/$/:sunsite/}
MASTER_SITE_SUBDIR= fetchmail/:DEFAULT \
system/mail/pop/fetchmail/:sunsite \
@@ -37,8 +38,6 @@ CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
--with-hesiod=no --enable-fallback=no PYTHON=:
# bsd.openssl.mk will add the LDFLAGS to CONFIGURE_ENV:
LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
MLINKS= fetchmail.1 fetchmailconf.1
@@ -49,14 +48,15 @@ OPTIONS= X11 "Python/Tkinter dependencies for fetchmailconf" off \
POP2 "Build pop2 support (obsolete)." off \
GSSAPI "Build GSSAPI support (requires KRB5_HOME to be set)" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_X11)
USE_PYTHON= yes
-.include "${PORTSDIR}/Mk/bsd.python.mk"
RUN_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
+.include <bsd.port.pre.mk>
+
# Pop2 is obsolete
.if defined(WITH_POP2)
CONFIGURE_ARGS+=--enable-POP2
@@ -128,7 +128,7 @@ pre-configure:
@${ECHO_CMD} "Unable to detect Kerberos in your system. Disabling GSSAPI support."
.endif
.else
- @${ECHO_CMD} "GSSAPI requires Kerberos which is not enabled in your current configuration."
+ @${ECHO_CMD} "GSSAPI requires Kerberos, but Kerberos is disabled."
.endif
.endif
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index f11be466a488..36811cca6a1b 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-MD5 (fetchmail-6.3.9.tar.bz2) = 72c20ad2b9629f1a109668b05a84d823
-SHA256 (fetchmail-6.3.9.tar.bz2) = 3dfd3b04aa552331f91f96bdf5f5afe489c31a600ae7973f5814bde5555813dc
-SIZE (fetchmail-6.3.9.tar.bz2) = 1538134
+MD5 (fetchmail-6.3.10.tar.bz2) = 50f6c7d2c400c6521dec3da459ae30c4
+SHA256 (fetchmail-6.3.10.tar.bz2) = d3a22d81990908f7df4bfd25f12b9e41303e956b3e70d7447356cf92ad7f6607
+SIZE (fetchmail-6.3.10.tar.bz2) = 1608066
diff --git a/mail/fetchmail/files/patch-Makefile.in b/mail/fetchmail/files/patch-Makefile.in
deleted file mode 100644
index 18481ce617d6..000000000000
--- a/mail/fetchmail/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu Dec 1 00:33:52 2005
-+++ Makefile.in Sun Dec 11 21:58:15 2005
-@@ -29,7 +29,7 @@
- INSTALL = @INSTALL@
- install_sh_DATA = $(install_sh) -c -m 644
- install_sh_PROGRAM = $(install_sh) -c
--install_sh_SCRIPT = $(install_sh) -c
-+install_sh_SCRIPT = $(install_sh) -c -m 555
- INSTALL_HEADER = $(INSTALL_DATA)
- transform = $(program_transform_name)
- NORMAL_INSTALL = :
diff --git a/mail/fetchmail/files/patch-fetchlimit-exitstatus b/mail/fetchmail/files/patch-fetchlimit-exitstatus
deleted file mode 100644
index dd79d235ffe5..000000000000
--- a/mail/fetchmail/files/patch-fetchlimit-exitstatus
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: driver.c
-===================================================================
---- driver.c (Revision 5254)
-+++ driver.c (Revision 5255)
-@@ -1435,9 +1435,11 @@
- /* end-of-mailbox processing before we repoll or switch to another one */
- if (ctl->server.base_protocol->end_mailbox_poll)
- {
-- err = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
-- if (err)
-+ tmperr = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
-+ if (tmperr) {
-+ err = tmperr;
- goto cleanUp;
-+ }
- }
- /* Return now if we have reached the fetchlimit */
- if (maxfetch && maxfetch <= fetches)
diff --git a/mail/fetchmail/pkg-plist b/mail/fetchmail/pkg-plist
index bdce315d512f..d72f0766e271 100644
--- a/mail/fetchmail/pkg-plist
+++ b/mail/fetchmail/pkg-plist
@@ -25,6 +25,7 @@ libexec/fetchmailconf.py
%%NLS%%share/locale/fr/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/gl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/id/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/it/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/ja/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/nl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/pl/LC_MESSAGES/fetchmail.mo