aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-01-11 06:36:28 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-01-11 06:36:28 +0000
commit56147f1c5dbe7beb08e17051b84f1814d0225741 (patch)
treeb4ed45e98af4d44b9c305a513e5e6c5839a303e9 /mail/fetchmail
parentb322a58cc4a350f7cdb6dbce264b727896af1b8b (diff)
downloadports-56147f1c5dbe7beb08e17051b84f1814d0225741.tar.gz
ports-56147f1c5dbe7beb08e17051b84f1814d0225741.zip
Notes
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile26
-rw-r--r--mail/fetchmail/files/patch-configure30
-rw-r--r--mail/fetchmail/files/patch-configure.ac24
3 files changed, 44 insertions, 36 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 38a51094cb44..654cdfd2bc39 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -3,15 +3,13 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.26
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= mail ipv6
MASTER_SITES= SF/${PORTNAME}/branch_6.3/ \
http://mandree.home.pages.de/${PORTNAME}/
-PATCH_SITES= https://gitlab.com/fetchmail/fetchmail/commit/:gitlab
-PATCH_SITES+= https://src.fedoraproject.org/rpms/fetchmail/raw/master/f/:fedora
-PATCHFILES= 9b8b634.patch:-p1:gitlab # SNI fix
-PATCHFILES+= fetchmail-6.3.26-ssl-backport.patch:-p1:fedora
+PATCH_SITES= https://src.fedoraproject.org/rpms/fetchmail/raw/master/f/:fedora
+PATCHFILES= fetchmail-6.3.26-ssl-backport.patch:-p1:fedora
MAINTAINER= chalpin@cs.wisc.edu
@@ -25,7 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USERS= ${PORTNAME}
GROUPS= ${USERS}
-USES= cpe gmake python shebangfix tar:xz ssl
+USES= autoreconf:build cpe gmake python shebangfix tar:xz ssl
SHEBANG_FILES= fetchmailconf.py
USE_RC_SUBR= fetchmail
@@ -80,6 +78,22 @@ post-patch:
@${REINPLACE_CMD} -e "s,-lcom_err,,g" ${WRKSRC}/configure
.endif
+# This is a workaround for a ports framework bug:
+# As of r489889 on 2019-01-10,
+# USES=autoreconf does not seem to get along with disabling the NLS option,
+# because this would not install gettext-tools, omitting autopoint,
+# however the configure.ac requests GETTEXT, so autoreconf will barf.
+# Pulling in gettext-tools unconditionally (even with NLS off) would
+# be excess and confuse users, so is not an option.
+# Thus we set USES=autoreconf:build and run autoreconf by ourselves,
+# overriding AUTOPOINT=true.
+#
+pre-configure-NLS-on:
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoreconf -f -i)
+#
+pre-configure-NLS-off:
+ (cd ${WRKSRC} && ${SETENV} AUTOPOINT=${TRUE} ${LOCALBASE}/bin/autoreconf -f -i)
+
post-build:
@${MAKE_CMD} -C ${WRKSRC} check
diff --git a/mail/fetchmail/files/patch-configure b/mail/fetchmail/files/patch-configure
deleted file mode 100644
index 16336221ff4e..000000000000
--- a/mail/fetchmail/files/patch-configure
+++ /dev/null
@@ -1,30 +0,0 @@
---- configure.orig 2013-04-23 14:36:55.000000000 -0700
-+++ configure 2018-04-21 22:45:30.073773000 -0700
-@@ -9552,11 +9552,11 @@
- #ifdef __cplusplus
- extern "C"
- #endif
--char krb5_des_string_to_key ();
-+char krb5int_des_string_to_key ();
- int
- main ()
- {
--return krb5_des_string_to_key ();
-+return krb5int_des_string_to_key ();
- ;
- return 0;
- }
-@@ -9591,11 +9591,11 @@
- #ifdef __cplusplus
- extern "C"
- #endif
--char krb5_des_string_to_key ();
-+char krb5int_des_string_to_key ();
- int
- main ()
- {
--return krb5_des_string_to_key ();
-+return krb5int_des_string_to_key ();
- ;
- return 0;
- }
diff --git a/mail/fetchmail/files/patch-configure.ac b/mail/fetchmail/files/patch-configure.ac
new file mode 100644
index 000000000000..a84e3216616d
--- /dev/null
+++ b/mail/fetchmail/files/patch-configure.ac
@@ -0,0 +1,24 @@
+--- configure.ac.orig 2013-04-23 20:51:10 UTC
++++ configure.ac
+@@ -19,7 +19,7 @@ AC_CANONICAL_HOST
+ dnl automake options are in Makefile.am
+ AC_PREREQ(2.60)
+ dnl 2.60 required for AC_USE_SYSTEM_EXTENSIONS
+-AM_INIT_AUTOMAKE([silent-rules -Wall])
++AM_INIT_AUTOMAKE([silent-rules subdir-objects serial-tests])
+ AM_SILENT_RULES
+
+ dnl python is optional
+@@ -601,10 +601,10 @@ else
+ AC_MSG_RESULT([found])
+ ac_krblibs="-lcom_err"
+ AC_CHECK_LIB(crypto,
+- krb5_des_string_to_key,
++ krb5int_des_string_to_key,
+ libk5crypto=-lcrypto,
+ AC_CHECK_LIB(k5crypto,
+- krb5_des_string_to_key,
++ krb5int_des_string_to_key,
+ libk5crypto=-lk5crypto,
+ AC_MSG_ERROR([Kerberos 5 DES libraries not found]),
+ ${LDFLAGS} ${ac_krblibs}),