aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchyahoo/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-09-27 17:53:02 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-09-27 17:53:02 +0000
commit2d99e48c85d96d98cdcf95331a49c1554a4738a3 (patch)
treecee19d1a56102286f23ce1eadfc359de8ca10a0e /mail/fetchyahoo/Makefile
parentc36c2c38febd2a554b81585aa341858b8ba80534 (diff)
downloadports-2d99e48c85d96d98cdcf95331a49c1554a4738a3.tar.gz
ports-2d99e48c85d96d98cdcf95331a49c1554a4738a3.zip
Notes
Diffstat (limited to 'mail/fetchyahoo/Makefile')
-rw-r--r--mail/fetchyahoo/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/mail/fetchyahoo/Makefile b/mail/fetchyahoo/Makefile
new file mode 100644
index 000000000000..9149845c7825
--- /dev/null
+++ b/mail/fetchyahoo/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: fetchyahoo
+# Date created: 2003-09-27
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= fetchyahoo
+PORTVERSION= 2.5.3
+CATEGORIES= mail
+MASTER_SITES= http://fetchyahoo.sourceforge.net/
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Download e-mail from a Yahoo account to a Berkeley mailbox
+
+RUN_DEPENDS= \
+ encode-base64:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/IO/Lines.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/MIME/Body.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
+ ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/mach/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${LOCALBASE}/include/w3c-libwww/HTANSI.h:${PORTSDIR}/www/libwww \
+ ${SITE_PERL}/mach/HTML/Filter.pm:${PORTSDIR}/www/p5-HTML-Parser
+
+DOCS= COPYING ChangeLog Credits INSTALL TODO index.html
+MAN1= fetchyahoo.1
+NO_BUILD= yes
+PLIST= ${WRKDIR}/pkg-plist
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}/fetchyahoo-2.5
+
+.include <bsd.port.pre.mk>
+
+do-patch:
+# Use an RFC 2606 domain: myhost.com is registered.
+ ${PERL} -pi -e "s:myhost.com:example:g" ${WRKSRC}/fetchyahoorc
+
+pre-install:
+ ${ECHO_CMD} bin/fetchyahoo.pl > ${PLIST}
+.if !defined(NOPORTDOCS)
+ ${ECHO_CMD} share/examples/fetchyahoo/fetchyahoorc >> ${PLIST}
+.for ii in ${DOCS}
+ ${ECHO_CMD} share/doc/fetchyahoo/${ii} >> ${PLIST}
+.endfor
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/fetchyahoo.pl ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/fetchyahoorc ${EXAMPLESDIR}
+.for ii in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>