aboutsummaryrefslogtreecommitdiff
path: root/mail/firetray/Makefile
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2010-09-06 08:28:59 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2010-09-06 08:28:59 +0000
commitbfa804e89eb4f4c746d4d120d9f4457a191211e5 (patch)
tree355f0e295ea9f2de900f22018d75a44ac7997fb1 /mail/firetray/Makefile
parent39f6f921efd93257ddfc5b36bd896bdc065820e8 (diff)
Firetray is a system tray add-on for firefox.
WWW: http://code.google.com/p/firetray/ PR: ports/150048 Submitted by: Andriy Gapon <avg at icyb dot net dot ua> Approved by: beat (co-mentor)
Notes
Notes: svn path=/head/; revision=260633
Diffstat (limited to 'mail/firetray/Makefile')
-rw-r--r--mail/firetray/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/mail/firetray/Makefile b/mail/firetray/Makefile
new file mode 100644
index 000000000000..13780f11055c
--- /dev/null
+++ b/mail/firetray/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: firetray
+# Date created: 2010-08-27
+# Whom: Andriy Gapon <avg@icyb.net.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= firetray
+DISTVERSION= 0.2.8
+CATEGORIES= mail www
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= avg@icyb.net.ua
+COMMENT= System tray add-on for firefox, thunderbird, seamonkey, etc
+
+PATCH_DEPENDS= nspr>=4.8:${PORTSDIR}/devel/nspr \
+ pkg-config:${PORTSDIR}/devel/pkg-config
+
+USE_ZIP= yes
+USE_GECKO= libxul
+USE_SCONS= yes
+USE_GNOME= pkgconfig
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+GECKO_CONFIG= ${LOCALBASE}/bin/pkg-config ${GECKO}
+
+BUILD_SH_FLAGS= --dynamic-linking \
+ --gecko-sdk-bin=`${DIRNAME} ${XPIDL}` \
+ --gecko-sdk-lib=`${GECKO_CONFIG} --variable=sdkdir`/lib \
+ --gecko-sdk-idl=`${GECKO_CONFIG} --variable=idldir` \
+ --gecko-sdk-include=`${GECKO_CONFIG} --variable=includedir`
+NSPR_INCLUDE= `${LOCALBASE}/bin/pkg-config nspr --variable=includedir`
+
+PLIST_DIRS= ${DATADIR:S,${PREFIX}/,,}
+PLIST_FILES= ${DATADIR:S,${PREFIX}/,,}/${PORTNAME}.xpi
+
+post-patch:
+ @${REINPLACE_CMD} s,/usr/include/nspr,${NSPR_INCLUDE}, \
+ ${WRKSRC}/components/SConscript
+
+do-build:
+ cd ${WRKSRC} && ./build.sh ${BUILD_SH_FLAGS}
+
+do-install:
+ ${MKDIR} ${DATADIR} && \
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.xpi ${DATADIR}
+
+.include <bsd.port.mk>