aboutsummaryrefslogtreecommitdiff
path: root/mail/gbiff
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-12-22 22:28:09 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-12-22 22:28:09 +0000
commit312c103913d5302c0dcab28032122272f68877c1 (patch)
tree33aee0f0170a64346d98d525946101c269a1ad2f /mail/gbiff
parent0e9aae98e0d662d24b08b519925816eb246ee026 (diff)
downloadports-312c103913d5302c0dcab28032122272f68877c1.tar.gz
ports-312c103913d5302c0dcab28032122272f68877c1.zip
Notes
Diffstat (limited to 'mail/gbiff')
-rw-r--r--mail/gbiff/Makefile15
-rw-r--r--mail/gbiff/distinfo2
-rw-r--r--mail/gbiff/files/patch-aa20
-rw-r--r--mail/gbiff/files/patch-ab17
-rw-r--r--mail/gbiff/files/patch-ac15
-rw-r--r--mail/gbiff/pkg-plist6
6 files changed, 15 insertions, 60 deletions
diff --git a/mail/gbiff/Makefile b/mail/gbiff/Makefile
index ed14cff98f16..62497c7c23bf 100644
--- a/mail/gbiff/Makefile
+++ b/mail/gbiff/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gbiff
-PORTVERSION= 2.4a
-PORTREVISION= 1
+PORTVERSION= 3.0
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,15 +14,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= nakai@FreeBSD.org
USE_X_PREFIX= yes
-USE_GMAKE= yes
USE_GNOME= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|`gtk-config --cflags`|`\$$GTK_CONFIG --cflags`|g ; \
+ s|`gtk-config --libs`|`\$$GTK_CONFIG --libs`|g ; \
+ s|<iconv.h>|<giconv.h>|g ; \
+ s|-liconv|-lgiconv|g ; \
+ s|DATADIRNAME}"|DATADIRNAME}/gnome"|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/mail/gbiff/distinfo b/mail/gbiff/distinfo
index 432bf4b2d35a..de01e449b058 100644
--- a/mail/gbiff/distinfo
+++ b/mail/gbiff/distinfo
@@ -1 +1 @@
-MD5 (gbiff-2.4a.tar.gz) = 9aefbca00c70bfc5538075e05269436c
+MD5 (gbiff-3.0.tar.gz) = 2b712902ce0c4a29fd35f4be80b3180d
diff --git a/mail/gbiff/files/patch-aa b/mail/gbiff/files/patch-aa
deleted file mode 100644
index 672d9d860880..000000000000
--- a/mail/gbiff/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/protocol.c.orig Sat Mar 31 22:01:07 2001
-+++ src/protocol.c Sat Mar 31 22:01:39 2001
-@@ -392,7 +392,7 @@
- sup_bound = 0;
- range_end = 0;
- while (fgets (line, 4095, file)) {
-- if strstr (line, "unseen:") {
-+ if(strstr (line, "unseen:")){
- buffer = line + strlen ("unseen: ");
-
- while (*buffer != '\n') {
-@@ -550,7 +550,7 @@
- sup_bound = 0;
- range_end = 0;
- while (fgets (line, 4095, file)) {
-- if strstr (line, "unseen:") {
-+ if(strstr (line, "unseen:")){
- buffer = line + strlen ("unseen: ");
- while (*buffer != '\n') {
- /*
diff --git a/mail/gbiff/files/patch-ab b/mail/gbiff/files/patch-ab
deleted file mode 100644
index ae9b015601a0..000000000000
--- a/mail/gbiff/files/patch-ab
+++ /dev/null
@@ -1,17 +0,0 @@
---- configure.orig Sat Mar 31 22:26:45 2001
-+++ configure Sat Mar 31 22:27:00 2001
-@@ -3834,12 +3834,12 @@
-
- if test "x${prefix}" = "xNONE"; then
- cat >> confdefs.h <<EOF
--#define PACKAGE_DATA_DIR "${ac_default_prefix}/${DATADIRNAME}"
-+#define PACKAGE_DATA_DIR "${ac_default_prefix}/${DATADIRNAME}/gnome"
- EOF
-
- else
- cat >> confdefs.h <<EOF
--#define PACKAGE_DATA_DIR "${prefix}/${DATADIRNAME}"
-+#define PACKAGE_DATA_DIR "${prefix}/${DATADIRNAME}/gnome"
- EOF
-
- fi
diff --git a/mail/gbiff/files/patch-ac b/mail/gbiff/files/patch-ac
deleted file mode 100644
index cfee2d8f4c0e..000000000000
--- a/mail/gbiff/files/patch-ac
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/gbiff.c.orig Fri Mar 23 05:47:18 2001
-+++ src/gbiff.c Thu Apr 12 03:17:41 2001
-@@ -25,12 +25,10 @@
- # include <gnome.h>
- # include <applet-widget.h>
- #endif
--#include <popt.h>
- #include <gtk/gtk.h>
- #include <string.h>
- #include <stdlib.h>
- #include <stdio.h>
--#include <popt.h>
-
- #include "protocol.h"
- #include "callbacks.h"
diff --git a/mail/gbiff/pkg-plist b/mail/gbiff/pkg-plist
index 0020e6ba0746..61442ecf1027 100644
--- a/mail/gbiff/pkg-plist
+++ b/mail/gbiff/pkg-plist
@@ -1,10 +1,14 @@
bin/gbiff
etc/CORBA/servers/gbiff.gnorba
share/gnome/applets/Network/gbiff.desktop
+share/gnome/locale/fr/LC_MESSAGES/gbiff.mo
+share/gnome/pixmaps/gbiff/gbiff.png
share/gnome/pixmaps/gbiff/gnome-mail.xpm
share/gnome/pixmaps/gbiff/gnome-nomail.xpm
share/gnome/pixmaps/gbiff/gtk-mail.xpm
share/gnome/pixmaps/gbiff/gtk-nomail.xpm
+share/gnome/pixmaps/gbiff/logo.xpm
+share/gnome/pixmaps/gbiff/play.xpm
share/gnome/sounds/gbiff/mail.wav
-@dirrm share/gnome/pixmaps/gbiff
@dirrm share/gnome/sounds/gbiff
+@dirrm share/gnome/pixmaps/gbiff