aboutsummaryrefslogtreecommitdiff
path: root/mail/geary/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-01 11:12:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-01 11:12:04 +0000
commit64575be53237548c43cec3d8d86641bca7c9c9e0 (patch)
treecdb426542bf4aca133e0703a92bebbde05ed54be /mail/geary/Makefile
parent98e1843a9461fd9cdf423619c3f816f49a817daa (diff)
downloadports-64575be53237548c43cec3d8d86641bca7c9c9e0.tar.gz
ports-64575be53237548c43cec3d8d86641bca7c9c9e0.zip
Notes
Diffstat (limited to 'mail/geary/Makefile')
-rw-r--r--mail/geary/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/geary/Makefile b/mail/geary/Makefile
index ea162f75f24d..da389ca0ffa8 100644
--- a/mail/geary/Makefile
+++ b/mail/geary/Makefile
@@ -11,6 +11,9 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Mail client for GNOME 3
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= vapigen:lang/vala \
bash:shells/bash
LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
@@ -21,19 +24,17 @@ LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
libgcr-3.so:security/gcr
USES= cmake desktop-file-utils gettext \
- libtool pkgconfig shebangfix tar:xz
+ libtool localbase:ldflags pkgconfig shebangfix tar:xz
USE_GNOME= gnomedocutils gnomeprefix gtk30 intlhack
SHEBANG_FILES= desktop/geary-attach
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DNO_FATAL_WARNINGS:BOOL=ON
GLIB_SCHEMAS= org.yorba.geary.gschema.xml
post-patch:
- @${REINPLACE_CMD} -e 's|abort $$option||g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|abort $$option||g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>