aboutsummaryrefslogtreecommitdiff
path: root/mail/geary/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /mail/geary/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'mail/geary/Makefile')
-rw-r--r--mail/geary/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/geary/Makefile b/mail/geary/Makefile
new file mode 100644
index 000000000000..a9f403a8885d
--- /dev/null
+++ b/mail/geary/Makefile
@@ -0,0 +1,39 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/mail/geary/Makefile 19962 2014-10-15 14:57:24Z gusi $
+
+PORTNAME= geary
+PORTVERSION= 0.8.0
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Mail client for GNOME 3
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala \
+ bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= libgmime-2.6.so:${PORTSDIR}/mail/gmime26 \
+ libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libgcr-3.so:${PORTSDIR}/security/gcr
+
+USES= cmake desktop-file-utils gettext gmake \
+ libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomedocutils gnomeprefix gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.yorba.geary.gschema.xml
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|abort $$option||g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>