aboutsummaryrefslogtreecommitdiff
path: root/mail/getlive
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-10 16:49:17 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-10 16:49:17 +0000
commiteb572e5bf86eea898b166a230af948c5694739b8 (patch)
treea370f4976195d18936dfd6ab9d185bb6087c06a5 /mail/getlive
parentd79928d34fce8f845029e8f8270190f1bbce0582 (diff)
Notes
Diffstat (limited to 'mail/getlive')
-rw-r--r--mail/getlive/Makefile18
-rw-r--r--mail/getlive/distinfo4
-rw-r--r--mail/getlive/files/getlive.conf.sample88
3 files changed, 68 insertions, 42 deletions
diff --git a/mail/getlive/Makefile b/mail/getlive/Makefile
index 53416a4d3b6d..7e6705007fec 100644
--- a/mail/getlive/Makefile
+++ b/mail/getlive/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= getlive
-DISTVERSION= 2_7
+DISTVERSION= 3_0_3
CATEGORIES= mail
MASTER_SITES= http://tardisi.com/distfiles/ \
http://lawrencechen.net/distfiles/
@@ -14,7 +14,8 @@ COMMENT= Get mail from Hotmail (Live) mailboxes
RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
procmail:${PORTSDIR}/mail/procmail \
- p5-URI>=0:${PORTSDIR}/net/p5-URI
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-WWW-Mechanize-GZip>=0:${PORTSDIR}/www/p5-WWW-Mechanize-GZip
NO_BUILD= yes
USES= perl5
@@ -23,15 +24,10 @@ USE_PERL5= run
PLIST_FILES= bin/getlive etc/getlive.conf.sample
PORTDOCS= ChangeLog License Manual
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/GetLive.pl ${PREFIX}/bin/getlive
- ${INSTALL_DATA} ${FILESDIR}/getlive.conf.sample ${PREFIX}/etc
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/GetLive.pl ${STAGEDIR}${PREFIX}/bin/getlive
+ ${INSTALL_DATA} ${FILESDIR}/getlive.conf.sample ${STAGEDIR}${PREFIX}/etc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/mail/getlive/distinfo b/mail/getlive/distinfo
index c42b2141fd86..485db23961ad 100644
--- a/mail/getlive/distinfo
+++ b/mail/getlive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GetLive_2_7.tgz) = 166395e43ae65388845fd2cf511984b4a8ce793e94f7f91ba279a37dc49501d9
-SIZE (GetLive_2_7.tgz) = 29818
+SHA256 (GetLive_3_0_3.tgz) = bf2ae8c464b4c36ca65751be1b9698b1b4471348ae894cf46b57b255fa62f9c0
+SIZE (GetLive_3_0_3.tgz) = 27078
diff --git a/mail/getlive/files/getlive.conf.sample b/mail/getlive/files/getlive.conf.sample
index c34ab9e06826..470609b2703e 100644
--- a/mail/getlive/files/getlive.conf.sample
+++ b/mail/getlive/files/getlive.conf.sample
@@ -1,68 +1,98 @@
# UserName - YourHotmailUserName (without @something)
+#
UserName=
-# Password - YourHotmailPassword (so restrict the access rights to this configuration file.)
+# Password - YourHotmailPassword (so restrict the access rights to this
+# configuration file.)
+#
Password=
-# Domain - YourHotmailDomain (default 'hotmail.com', basically what's after the @ in your address)
+# Domain - YourHotmailDomain (default 'hotmail.com', basically what's after
+# the @ in your address)
+#
#Domain=hotmail.com
# Proxy - ProxyServer if you're behind one.
+#
#Proxy=
# ProxyAuth - ProxyPassword if you're behind one with password.
+#
#ProxyAuth=
# Downloaded - SomeFileName (it keeps track of all id's of messages
-# that were fetched already)
+# that were fetched already)
+#
Downloaded=
# FetchOnlyUnread - Yes or No (default)
-# If Yes only messages that are marked unread are fetched.
-# Downloaded and FetchOnlyUnread are mutual exclusive.
+#
+# If Yes only messages that are marked unread are fetched.
+# Downloaded and FetchOnlyUnread are mutual exclusive.
+#
#FetchOnlyUnread=No
-# RetryLimit - N (default 2) : how many times to retry fetching a
-# web page via curl (the webpage fetcher behind the scenes)
-#RetryLimit=2
-
-# CurlBin - CommandForCurl ('curl -k' by default).
-CurlBin=/usr/local/bin/curl -k
-
# Processor - FilterCommand ('/usr/bin/procmail' by default).
-# Any filtercommand taking the message in mbox format on its stdin and doing something with it.
+#
+# Any filtercommand taking the message in mbox format on its stdin
+# and doing something with it.
#
-# *) '/bin/cat - >> FetchedMail' might be another interesting one to drop directly in a mbox file.
+# *) '/bin/cat - >> FetchedMail' might be another interesting one to drop
+# directly in a mbox file.
#
# *) The distribution contains also SmtpForward.pl and SmtpAuthForward.pl.
# Those can be used as 'Processor' to forward the mails to an SMTP server.
+#
Processor=/usr/local/bin/procmail
-# Folder - FolderName. Folders that need to be fetched.
+# Folder - FolderName : Folders that need to be fetched.
+#
# This option must be repeated for each folder you want to fetch.
# If this option is not present then all folders will be fetched.
+#
#Folder=
-# MarkRead - Yes or No (default) : whether the message will be
-# marked read after being downloaded. By the way :
-# it never gets marked in any way when not downloaded due to it being already in the
-# Downloaded = SomeFileName (see higer) file.
+# MarkRead - Yes or No (default) : whether the message will be marked read
+# after being downloaded. By the way, it never
+# gets marked in any way when not downloaded
+# due to it being already in the
+# Downloaded = SomeFileName (see higher) file.
+#
#MarkRead=No
-# Delete - Yes or No (default) : whether the message will be
-# deleted after being downloaded. By the way :
-# it never gets deleted in any way when not downloaded due to it being already in the
-# Downloaded = SomeFileName (see higer) file.
+# Delete - Yes or No (default) : whether the message will be deleted after
+# being downloaded. By the way, it never gets
+# deleted in any way when not downloaded due to
+# it being already in the
+# Downloaded = SomeFileName (see higher) file.
+#
#Delete=No
# MoveToFolder - FolderName or @FileName
-# FolderName is the folder to which the message must be moved after being downloaded.
-# By the way : it never gets moved in any way when not downloaded due to it
-# being already in the Downloaded = SomeFileName (see higer) file.
+#
+# FolderName is the folder to which the message must be moved after being
+# downloaded. By the way, it never gets moved in any way when not downloaded
+# due to it being already in the Downloaded = SomeFileName (see higher) file.
+#
# If this argument takes the form @FileName then the FolderName is taken from
# the contents of the file FileName.
+#
# The idea is that f.i. a spamfilter can decide to what folder it must be moved.
-# That spamfilter would be part of Processor = FilterCommand (see higher) and
-# write a FolderName (for instance Junk if considered junk) to the file FileName.
-#MoveToFolter=
+# That spamfilter would be part of Processor = FilterCommand (see higher) and
+# write a FolderName (for instance Junk if considered junk) to the file
+# FileName.
+#
+#MoveToFolder=
+
+# SkipTrash - Yes or No (default) : whether the message Trash folder will be
+# handled (default) or not.
+#
+#SkipTrash=No
+# BreakOnAlreadyDownloaded = Number
+#
+# Stop scanning a folder when detecting a seqeunce of Number messages that
+# is already downloaded. 0 means disabling this feature and is default.
+# Meant to reduce folder scanning.
+#
+#BreakOnAlreadyDownloaded=0