aboutsummaryrefslogtreecommitdiff
path: root/mail/glacier
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:17:31 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:17:31 +0000
commitc76cf46929051f9dd322487d888c82f104026e6d (patch)
treef415aeddadc6782b1474ebd88710bfa86cf08711 /mail/glacier
parentb7bdcd418e7aca3dd98409e16a4c4ae9bc289d02 (diff)
downloadports-c76cf46929051f9dd322487d888c82f104026e6d.tar.gz
ports-c76cf46929051f9dd322487d888c82f104026e6d.zip
Notes
Diffstat (limited to 'mail/glacier')
-rw-r--r--mail/glacier/Makefile12
-rw-r--r--mail/glacier/files/patch-aa11
2 files changed, 17 insertions, 6 deletions
diff --git a/mail/glacier/Makefile b/mail/glacier/Makefile
index 8aefdf5a9eae..af7d88902a40 100644
--- a/mail/glacier/Makefile
+++ b/mail/glacier/Makefile
@@ -12,13 +12,13 @@ MASTER_SITES= http://glacier.linuxave.net/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG}
-CONFIGURE_ARGS+=--datadir=${PREFIX}/share
USE_GMAKE= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+
+pre-patch:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
.include <bsd.port.mk>
diff --git a/mail/glacier/files/patch-aa b/mail/glacier/files/patch-aa
new file mode 100644
index 000000000000..988f80154cd2
--- /dev/null
+++ b/mail/glacier/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Sun Feb 27 16:05:09 2000
++++ configure Sun Feb 27 16:05:59 2000
+@@ -1333,7 +1333,7 @@
+ echo "configure:1334: checking for Gnome compile flags" >&5
+ GNOME_CFLAGS=`$gnomepath gnomeui --cflags 2>/dev/null`
+ GNOME_VER=`$gnomepath --version |$sedpath 's/gnome-libs //'`
+- GNOME_MINOR=`echo $GNOME_VER |$sedpath 's/\([0-9]**\).\([0-9]**\).\([0-9]**\)/\2/'`
++ GNOME_MINOR=`echo $GNOME_VER |$sedpath 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
+
+ if test "_$GNOME_MINOR" = "_20"; then
+ gnome=no