aboutsummaryrefslogtreecommitdiff
path: root/mail/gld
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:44:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:44:16 +0000
commitb7911e908773e41d198f4ec1c34e510a11c5ce60 (patch)
treea583a97af6879e3a9196277016eebcd4251a0f48 /mail/gld
parent64d9c2bb8c5d7ebeaa062dfdf032958514e2a572 (diff)
downloadports-b7911e908773e41d198f4ec1c34e510a11c5ce60.tar.gz
ports-b7911e908773e41d198f4ec1c34e510a11c5ce60.zip
Notes
Diffstat (limited to 'mail/gld')
-rw-r--r--mail/gld/Makefile50
-rw-r--r--mail/gld/distinfo2
-rw-r--r--mail/gld/files/MESSAGE.tmpl12
-rw-r--r--mail/gld/files/gld.sh.tmpl31
-rw-r--r--mail/gld/pkg-descr10
-rw-r--r--mail/gld/pkg-plist8
6 files changed, 113 insertions, 0 deletions
diff --git a/mail/gld/Makefile b/mail/gld/Makefile
new file mode 100644
index 000000000000..9cad7905da4d
--- /dev/null
+++ b/mail/gld/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: gld
+# Date created: 15 Jul 2004
+# Whom: Blaz Zupan <blaz@si.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gld
+PORTVERSION= 1.2
+CATEGORIES= mail
+MASTER_SITES= http://www.gasmi.net/down/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= blaz@si.FreeBSD.org
+COMMENT= Greylisting daemon for Postfix
+
+USE_MYSQL= yes
+USE_REINPLACE= yes
+USE_RC_SUBR= yes
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --with-mysql=${PREFIX}
+
+PKGMESSAGE= ${WRKDIR}/MESSAGE
+
+SED_SCRIPT= -e 's,%%DOCSDIR%%,${DOCSDIR},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g' \
+ -e 's,%%RC_SUBR%%,${RC_SUBR},g'
+
+pre-build:
+ ${REINPLACE_CMD} -e 's,"/etc/gld.conf","${PREFIX}/etc/gld.conf",' ${WRKSRC}/gld.h
+ for f in gld.sh MESSAGE; do \
+ ${SED} ${SED_SCRIPT} < ${FILESDIR}/$${f}.tmpl >> ${WRKDIR}/$${f}; \
+ done
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gld ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/gld.conf ${PREFIX}/etc/gld.conf-dist
+ ${INSTALL_SCRIPT} ${WRKDIR}/gld.sh ${PREFIX}/etc/rc.d
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in HISTORY LICENCE README tables.sql
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/gld/distinfo b/mail/gld/distinfo
new file mode 100644
index 000000000000..0b359dcd303e
--- /dev/null
+++ b/mail/gld/distinfo
@@ -0,0 +1,2 @@
+MD5 (gld-1.2.tgz) = 46c694a9796dd7dd114888489f19060c
+SIZE (gld-1.2.tgz) = 30924
diff --git a/mail/gld/files/MESSAGE.tmpl b/mail/gld/files/MESSAGE.tmpl
new file mode 100644
index 000000000000..a87ba03a3ea2
--- /dev/null
+++ b/mail/gld/files/MESSAGE.tmpl
@@ -0,0 +1,12 @@
+
+*******************************************************************
+ Enable gld in /etc/rc.conf with the following line:
+
+ gld_enable="YES"
+
+ To complete the installation, you need to create the neccesary
+ database and tables. An example configuration file is available in
+ %%PREFIX%%/etc/gld.conf-dist. For more information see the
+ documentation in %%DOCSDIR%%/share/doc/gld.
+*******************************************************************
+
diff --git a/mail/gld/files/gld.sh.tmpl b/mail/gld/files/gld.sh.tmpl
new file mode 100644
index 000000000000..a21aa5342b0b
--- /dev/null
+++ b/mail/gld/files/gld.sh.tmpl
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: gld
+# REQUIRE: LOGIN
+# BEFORE: mail
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable amavisd:
+#
+#gld_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=gld
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/gld
+
+required_files=%%PREFIX%%/etc/gld.conf
+
+# set defaults
+
+gld_enable=${amavisd_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/mail/gld/pkg-descr b/mail/gld/pkg-descr
new file mode 100644
index 000000000000..3eb5920a1de0
--- /dev/null
+++ b/mail/gld/pkg-descr
@@ -0,0 +1,10 @@
+Gld is a standalone greylisting server for Postfix.
+
+Greylisting is a new weapon to use against spam. For more information on
+this technique, see http://www.greylisting.org.
+
+This implementation listens on a TCP port and uses MySQL for storing data.
+The server supports whitelists based on sender, sender domain and client IP.
+It also supports light greylisting.
+
+WWW: http://www.gasmi.net/gld.html
diff --git a/mail/gld/pkg-plist b/mail/gld/pkg-plist
new file mode 100644
index 000000000000..6ea596881685
--- /dev/null
+++ b/mail/gld/pkg-plist
@@ -0,0 +1,8 @@
+etc/gld.conf-dist
+etc/rc.d/gld.sh
+sbin/gld
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY
+%%PORTDOCS%%%%DOCSDIR%%/LICENCE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/tables.sql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%