aboutsummaryrefslogtreecommitdiff
path: root/mail/gld
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-13 05:55:02 +0000
commit7da39d11c2a4d3613e19a4dc6a562337ba1bfacd (patch)
tree06c1fcce4e4bd9e8bdce472e8eca4f4a467896ca /mail/gld
parentc2894a8bc4d59836f188e71d0024673d696c7ec8 (diff)
Notes
Diffstat (limited to 'mail/gld')
-rw-r--r--mail/gld/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/mail/gld/Makefile b/mail/gld/Makefile
index dc2592dc9dc5..50bdd643ecc0 100644
--- a/mail/gld/Makefile
+++ b/mail/gld/Makefile
@@ -20,20 +20,18 @@ HAS_CONFIGURE= yes
SUB_FILES= pkg-message
-OPTIONS= MYSQL "MySQL support" on \
- PGSQL "PgSQL support" off \
- LOCAL_DB_SERVER "RUN_DEPEND also on selected DB server" off
+OPTIONS_SINGLE= DB
+OPTIONS_SINGLE_DB= MYSQL PGSQL
+OPTIONS_DEFINE= LOCAL_DB_SERVER
+OPTIONS_DEFAULT= MYSQL
+LOCAL_DB_SERVER_DESC= RUN_DEPEND also on selected DB server
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL) && defined(WITH_PGSQL)
-BROKEN= Cannot compile with both MySQL and PgSQL support
-.endif
-
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
USE_MYSQL= yes
-. if defined(WITH_LOCAL_DB_SERVER)
+. if ${PORT_OPTIONS:MLOCAL_DB_SERVER}
RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
SUB_LIST+= MYSQL=mysql
SUB_LIST+= PGSQL=
@@ -42,10 +40,10 @@ SUB_LIST+= MYSQL=
. endif
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
USE_PGSQL= yes
-. if defined(WITH_LOCAL_DB_SERVER)
+. if ${PORT_OPTIONS:MLOCAL_DB_SERVER}
RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
SUB_LIST+= PGSQL=postgresql
SUB_LIST+= MYSQL=
@@ -66,7 +64,7 @@ do-install:
.if !exists(${PREFIX}/etc/gld.conf)
${INSTALL_DATA} ${WRKSRC}/gld.conf ${PREFIX}/etc/gld.conf
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in HISTORY LICENCE README table-whitelist.sql tables.mysql tables.pgsql
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -76,4 +74,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>