aboutsummaryrefslogtreecommitdiff
path: root/mail/gmail-notify
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /mail/gmail-notify
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'mail/gmail-notify')
-rw-r--r--mail/gmail-notify/Makefile42
-rw-r--r--mail/gmail-notify/distinfo2
-rw-r--r--mail/gmail-notify/files/Makefile.in24
-rw-r--r--mail/gmail-notify/files/config.h6
-rw-r--r--mail/gmail-notify/files/gmail-notifier5
-rw-r--r--mail/gmail-notify/files/patch-GmailConfig.py157
-rw-r--r--mail/gmail-notify/files/patch-langs.xml11
-rw-r--r--mail/gmail-notify/files/patch-notifier.conf.sample13
-rw-r--r--mail/gmail-notify/files/patch-notifier.py46
-rw-r--r--mail/gmail-notify/pkg-descr5
-rw-r--r--mail/gmail-notify/pkg-plist16
11 files changed, 0 insertions, 327 deletions
diff --git a/mail/gmail-notify/Makefile b/mail/gmail-notify/Makefile
deleted file mode 100644
index d1282f8f9ad5..000000000000
--- a/mail/gmail-notify/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# Created by: David
-# $FreeBSD$
-
-PORTNAME= gmail-notify
-PORTVERSION= 1.6.1.1
-PORTREVISION= 5
-CATEGORIES= mail python
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= gahr@FreeBSD.org
-COMMENT= GMail Notifier
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/py-gnome-extras:extract
-
-USE_GNOME= pygtk2
-USES= gmake pkgconfig python
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-EXTRAS_DIR= ${PORTSDIR}/x11-toolkits/py-gnome-extras
-
-post-patch:
- ${SED} -e 's|@DATADIR@|${DATADIR}|' ${FILESDIR}/gmail-notifier > ${WRKSRC}/gmail-notifier
- ${SED} -e 's|@PYTHON_INCLUDEDIR@|${PYTHON_INCLUDEDIR}|' ${FILESDIR}/Makefile.in > ${WRKSRC}/Makefile
-
-pre-build:
- ${CP} `${MAKE} -C ${EXTRAS_DIR} -V WRKSRC`/egg/tray/eggtrayicon.[ch] ${WRKSRC}
- ${CP} `${MAKE} -C ${EXTRAS_DIR} -V WRKSRC`/egg/tray/trayicon* ${WRKSRC}
- ${CP} ${FILESDIR}/config.h ${WRKSRC}
- ${RM} ${WRKSRC}/pytrayicon.so
-
-do-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/gmail-notifier ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/*.py ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.png ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.jpg ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.so ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/langs.xml ${STAGEDIR}${DATADIR}
-
-.include <bsd.port.mk>
diff --git a/mail/gmail-notify/distinfo b/mail/gmail-notify/distinfo
deleted file mode 100644
index 80c79e6ad853..000000000000
--- a/mail/gmail-notify/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gmail-notify-1.6.1.1.tar.gz) = 96aa835c04a12d700621a7010c300f2146ca212aaebe92d2b8e8158024999de0
-SIZE (gmail-notify-1.6.1.1.tar.gz) = 32167
diff --git a/mail/gmail-notify/files/Makefile.in b/mail/gmail-notify/files/Makefile.in
deleted file mode 100644
index f74e771bba28..000000000000
--- a/mail/gmail-notify/files/Makefile.in
+++ /dev/null
@@ -1,24 +0,0 @@
-# $FreeBSD$
-# Makefile to build trayicon.so
-
-CFLAGS = `pkg-config --cflags gtk+-2.0 pygtk-2.0` -I@PYTHON_INCLUDEDIR@ -I. -Wall -I${LOCALBASE}/share/pygtk/2.0 -I${LOCALBASE}/libdata/pkgconfig -DEGG_COMPILATION -fPIC
-LDFLAGS = `pkg-config --libs gtk+-2.0 pygtk-2.0`
-
-DEFS_DIR= ${LOCALBASE}/share/pygtk/2.0/defs/
-
-CODEGEN = pygtk-codegen-2.0
-
-all: trayicon.so
-
-trayicon.so: trayicon.o eggtrayicon.o trayiconmodule.o
- $(CC) $(LDFLAGS) -shared $^ -o $@
-
-trayicon.c: trayicon.defs eggtrayicon.h trayicon.override
- $(CODEGEN) --prefix pytrayicon \
- --register $(DEFS_DIR)/gdk-types.defs \
- --register $(DEFS_DIR)/gtk-types.defs \
- --override trayicon.override \
- trayicon.defs > $@
-
-clean:
- rm -f *.o *.so trayicon.c *~
diff --git a/mail/gmail-notify/files/config.h b/mail/gmail-notify/files/config.h
deleted file mode 100644
index 284f0956e2bb..000000000000
--- a/mail/gmail-notify/files/config.h
+++ /dev/null
@@ -1,6 +0,0 @@
-/*
- * This file is empty. eggtrayicon.c includes a <config.h> even if it appears to
- * be useless.
- *
- * David <djulien.bsd@gmail.com>
- */
diff --git a/mail/gmail-notify/files/gmail-notifier b/mail/gmail-notify/files/gmail-notifier
deleted file mode 100644
index 002c6eb2056d..000000000000
--- a/mail/gmail-notify/files/gmail-notifier
+++ /dev/null
@@ -1,5 +0,0 @@
-#! /bin/sh
-# Launch notifier
-#
-# David <djulien.bsd@gmail.com>
-cd @DATADIR@ ; python notifier.py
diff --git a/mail/gmail-notify/files/patch-GmailConfig.py b/mail/gmail-notify/files/patch-GmailConfig.py
deleted file mode 100644
index c36c4b446c74..000000000000
--- a/mail/gmail-notify/files/patch-GmailConfig.py
+++ /dev/null
@@ -1,157 +0,0 @@
-*** GmailConfig.py.orig Sun Sep 25 19:12:11 2005
---- GmailConfig.py Wed Sep 28 22:27:48 2005
-***************
-*** 18,24 ****
- configElements = None
-
- # Declare global variables for configuration as dictionary
-! options = { "gmailusername":None, "gmailpassword":None, "browserpath":"firefox", "lang":"English",
- "voffset":0, "hoffset":0, "checkinterval":20000,
- "animationdelay":15, "popuptimespan":5000}
-
---- 18,24 ----
- configElements = None
-
- # Declare global variables for configuration as dictionary
-! options = { "gmailusername":None, "gmailpassword":None, "browserpath":"firefox", "lang":"English", "actionpath":"play",
- "voffset":0, "hoffset":0, "checkinterval":20000,
- "animationdelay":15, "popuptimespan":5000}
-
-***************
-*** 36,43 ****
- self.window.set_title( self.lang.get_string(1) )
- self.window.set_border_width( 5 )
- self.window.set_position( gtk.WIN_POS_CENTER )
-! self.window.set_modal( gtk.TRUE )
-! self.window.set_resizable(gtk.FALSE)
- icon = gtk.gdk.pixbuf_new_from_file(ICON_PATH)
- gtk.window_set_default_icon_list( (icon) )
-
---- 36,43 ----
- self.window.set_title( self.lang.get_string(1) )
- self.window.set_border_width( 5 )
- self.window.set_position( gtk.WIN_POS_CENTER )
-! self.window.set_modal( True )
-! self.window.set_resizable(False)
- icon = gtk.gdk.pixbuf_new_from_file(ICON_PATH)
- gtk.window_set_default_icon_list( (icon) )
-
-***************
-*** 49,54 ****
---- 49,55 ----
- ["gmailusername",2,None,None],
- ["gmailpassword",22,None,None],
- ["browserpath",3,None,None],
-+ ["actionpath",99,None,None],
- ["voffset",28,None,None],
- ["hoffset",27,None,None],
- ["checkinterval",31,None,None],
-***************
-*** 57,63 ****
- ]
-
- # Create table and attach to window
-! table = gtk.Table( rows=11, columns=2, homogeneous=gtk.FALSE )
-
- self.window.add(table)
-
---- 58,64 ----
- ]
-
- # Create table and attach to window
-! table = gtk.Table( rows=12, columns=2, homogeneous=False )
-
- self.window.add(table)
-
-***************
-*** 74,80 ****
- textbox.set_text( str( self.options[curVar] ) )
-
- if ( curVar == "gmailpassword" ):
-! textbox.set_visibility( gtk.FALSE )
- textbox.set_invisible_char( '*' )
-
- # Store widget in element array
---- 75,81 ----
- textbox.set_text( str( self.options[curVar] ) )
-
- if ( curVar == "gmailpassword" ):
-! textbox.set_visibility( False )
- textbox.set_invisible_char( '*' )
-
- # Store widget in element array
-***************
-*** 109,120 ****
-
-
- if ( self.readLoginFromFile ):
-! self.savePassword.set_active( gtk.TRUE )
- else:
-! self.savePassword.set_active( gtk.FALSE )
-
- self.savePassword.show()
-! table.attach( alignment, 0, 2, 9, 10 )
- alignment.show()
-
- # Add combobox to select language
---- 110,121 ----
-
-
- if ( self.readLoginFromFile ):
-! self.savePassword.set_active( True )
- else:
-! self.savePassword.set_active( False )
-
- self.savePassword.show()
-! table.attach( alignment, 0, 2, 10, 11 )
- alignment.show()
-
- # Add combobox to select language
-***************
-*** 129,142 ****
- self.cbo_langs.append_text( one_lang.get_name())
- self.cbo_langs.set_active(0)
- # Attach combobox and label
-! table.attach( self.lbl_langs, 0, 1, 8, 9 )
- self.lbl_langs.show()
-! table.attach( self.cbo_langs, 1, 2, 8, 9, ypadding=5 )
- self.cbo_langs.show()
-
- # Add 'Close' button
- button = gtk.Button( stock=gtk.STOCK_OK )
-! table.attach( button, 0, 2, 10, 11, ypadding=2 )
- button.connect( "clicked", self.onOkay )
- button.show()
-
---- 130,143 ----
- self.cbo_langs.append_text( one_lang.get_name())
- self.cbo_langs.set_active(0)
- # Attach combobox and label
-! table.attach( self.lbl_langs, 0, 1, 9, 10 )
- self.lbl_langs.show()
-! table.attach( self.cbo_langs, 1, 2, 9, 10, xpadding=0, ypadding=5 )
- self.cbo_langs.show()
-
- # Add 'Close' button
- button = gtk.Button( stock=gtk.STOCK_OK )
-! table.attach( button, 0, 2, 11, 12, xpadding=0, ypadding=2 )
- button.connect( "clicked", self.onOkay )
- button.show()
-
-***************
-*** 206,212 ****
- def onDelete( self, widget, data=None ):
- gtk.main_quit()
- self.hide()
-! return gtk.TRUE
-
- def onOkay( self, widget, callback_data=None ):
- errorString = ""
---- 207,213 ----
- def onDelete( self, widget, data=None ):
- gtk.main_quit()
- self.hide()
-! return True
-
- def onOkay( self, widget, callback_data=None ):
- errorString = ""
diff --git a/mail/gmail-notify/files/patch-langs.xml b/mail/gmail-notify/files/patch-langs.xml
deleted file mode 100644
index a6c39b701afe..000000000000
--- a/mail/gmail-notify/files/patch-langs.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-*** langs.xml.orig Tue May 3 10:02:33 2005
---- langs.xml Tue Jun 7 15:28:53 2005
-***************
-*** 67,71 ****
---- 68,73 ----
- <string id="32">Intervalo e/conexiones</string>
- <string id="33">Falta completar algún valor</string>
- <string id="34">Guardar nombre de usuario y contraseña</string>
-+ <string id="99" >Acción</string>
- </lang>
- </langs>
diff --git a/mail/gmail-notify/files/patch-notifier.conf.sample b/mail/gmail-notify/files/patch-notifier.conf.sample
deleted file mode 100644
index 84cf75884575..000000000000
--- a/mail/gmail-notify/files/patch-notifier.conf.sample
+++ /dev/null
@@ -1,13 +0,0 @@
-*** notifier.conf.sample.orig Wed Sep 28 22:36:37 2005
---- notifier.conf.sample Wed Sep 28 22:36:53 2005
-***************
-*** 6,11 ****
---- 6,13 ----
- lang = English
- browserpath = your_browser_path
-
-+ play = action_to_do_when_new_mails
-+
- # account information
- gmailusername = your_gmail_username
- gmailpassword = your_gmail_password
diff --git a/mail/gmail-notify/files/patch-notifier.py b/mail/gmail-notify/files/patch-notifier.py
deleted file mode 100644
index e275f4d37cb7..000000000000
--- a/mail/gmail-notify/files/patch-notifier.py
+++ /dev/null
@@ -1,46 +0,0 @@
-*** notifier.py.orig Tue May 3 10:02:33 2005
---- notifier.py Thu Jun 23 23:30:03 2005
-***************
-*** 7,13 ****
- import time
- import libgmail
- import os
-! import pytrayicon
- import sys
- import warnings
- import ConfigParser
---- 7,13 ----
- import time
- import libgmail
- import os
-! import trayicon
- import sys
- import warnings
- import ConfigParser
-***************
-*** 82,88 ****
- self.popuptimer=0
- self.waittimer=0
- # Create the tray icon object
-! self.tray = pytrayicon.TrayIcon(self.lang.get_string(21));
- self.eventbox = gtk.EventBox()
- self.tray.add(self.eventbox)
- self.eventbox.connect("button_press_event", self.tray_icon_clicked)
---- 82,88 ----
- self.popuptimer=0
- self.waittimer=0
- # Create the tray icon object
-! self.tray = trayicon.TrayIcon(self.lang.get_string(21));
- self.eventbox = gtk.EventBox()
- self.tray.add(self.eventbox)
- self.eventbox.connect("button_press_event", self.tray_icon_clicked)
-***************
-*** 205,210 ****
---- 205,211 ----
- self.imageicon = gtk.Image()
-
- if attrs[1]>0:
-+ os.system(self.options['actionpath']+" &")
- print str(attrs[1])+" new messages"
- sender = attrs[2]
- subject= attrs[3]
diff --git a/mail/gmail-notify/pkg-descr b/mail/gmail-notify/pkg-descr
deleted file mode 100644
index 79e214d150d6..000000000000
--- a/mail/gmail-notify/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Gmail Notifier is a Linux/Windows alternative for the notifier program released
-by Google. It is written in Python and provides an attractive and simple way to
-check for new mail messages.
-
-WWW: http://sourceforge.net/projects/gmail-notify
diff --git a/mail/gmail-notify/pkg-plist b/mail/gmail-notify/pkg-plist
deleted file mode 100644
index 4e240d9666c7..000000000000
--- a/mail/gmail-notify/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-bin/gmail-notifier
-%%DATADIR%%/GmailConfig.py
-%%DATADIR%%/GmailPopupMenu.py
-%%DATADIR%%/README
-%%DATADIR%%/background.jpg
-%%DATADIR%%/gmail-notify-icon.png
-%%DATADIR%%/gmailatom.py
-%%DATADIR%%/icon.jpg
-%%DATADIR%%/icon.png
-%%DATADIR%%/icon2.jpg
-%%DATADIR%%/icon2.png
-%%DATADIR%%/langs.xml
-%%DATADIR%%/notifier.py
-%%DATADIR%%/trayicon.so
-%%DATADIR%%/xmllangs.py
-@dirrm %%DATADIR%%