aboutsummaryrefslogtreecommitdiff
path: root/mail/gmime2
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-02 10:32:04 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-02 10:32:04 +0000
commitdad554421422342444ec4b3e34185a44230fa92e (patch)
tree7c59a7cda3ca54e8c0a86a34336dd3fedce831ac /mail/gmime2
parentea61e46c4e87d5162d2bdb65a59f97791ccfee57 (diff)
downloadports-dad554421422342444ec4b3e34185a44230fa92e.tar.gz
ports-dad554421422342444ec4b3e34185a44230fa92e.zip
mail/gmime2: Add PORTSCOUT variable to limit within 2.2.X
- Fix patch files to reflect 'make makepatch'
Notes
Notes: svn path=/head/; revision=388320
Diffstat (limited to 'mail/gmime2')
-rw-r--r--mail/gmime2/Makefile1
-rw-r--r--mail/gmime2/files/patch-docs_Makefile.in8
-rw-r--r--mail/gmime2/files/patch-gmime-2.0.pc.in8
-rw-r--r--mail/gmime2/files/patch-mono_Makefile.in6
-rw-r--r--mail/gmime2/files/patch-tests__test-mbox.c8
-rw-r--r--mail/gmime2/files/patch-tests__test-mime.c10
-rw-r--r--mail/gmime2/files/patch-tests__test-parser.c6
7 files changed, 24 insertions, 23 deletions
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index d726b42bc971..d6682fd8f6ef 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -13,6 +13,7 @@ COMMENT?= Library (written in C) for parsing and creating messages using MIME
LICENSE= LGPL21
+PORTSCOUT= limit:^2\.2
CONFLICTS= gmime-1.0.* gmime-2.4.*
SLAVEDIRS= mail/gmime2-sharp
diff --git a/mail/gmime2/files/patch-docs_Makefile.in b/mail/gmime2/files/patch-docs_Makefile.in
index 09fa5b5faa8e..2fd5cee2f63b 100644
--- a/mail/gmime2/files/patch-docs_Makefile.in
+++ b/mail/gmime2/files/patch-docs_Makefile.in
@@ -1,7 +1,7 @@
---- docs/Makefile.in.orig 2008-01-03 09:05:09.000000000 -0200
-+++ docs/Makefile.in 2008-01-03 09:05:21.000000000 -0200
-@@ -193,7 +193,7 @@
- target_alias = @target_alias@
+--- docs/Makefile.in.orig 2015-06-02 10:27:29 UTC
++++ docs/Makefile.in
+@@ -229,7 +229,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = reference tutorial
diff --git a/mail/gmime2/files/patch-gmime-2.0.pc.in b/mail/gmime2/files/patch-gmime-2.0.pc.in
index 21772930dd0b..9dc471ae4327 100644
--- a/mail/gmime2/files/patch-gmime-2.0.pc.in
+++ b/mail/gmime2/files/patch-gmime-2.0.pc.in
@@ -1,10 +1,10 @@
---- gmime-2.0.pc.in.orig Tue May 3 19:34:20 2005
-+++ gmime-2.0.pc.in Wed Feb 1 00:51:53 2006
-@@ -7,6 +7,6 @@
+--- gmime-2.0.pc.in.orig 2011-03-07 18:09:21 UTC
++++ gmime-2.0.pc.in
+@@ -7,6 +7,6 @@ includedir=@includedir@
Name: GMime
Version: @VERSION@
Description: MIME parser and utility library
-Requires: glib-2.0,gobject-2.0
+Requires: glib-2.0,gobject-2.0,gthread-2.0
- Libs: -L${libdir} @GMIME_LIBS@ @LIBS@
+ Libs: -L${libdir} @GMIME_LIBS@
Cflags: -I${includedir}/gmime-2.0 @GMIME_CFLAGS@
diff --git a/mail/gmime2/files/patch-mono_Makefile.in b/mail/gmime2/files/patch-mono_Makefile.in
index 67b3dbf59af4..0dc8314b7022 100644
--- a/mail/gmime2/files/patch-mono_Makefile.in
+++ b/mail/gmime2/files/patch-mono_Makefile.in
@@ -1,6 +1,6 @@
---- mono/Makefile.in.orig Sun Sep 11 23:59:29 2005
-+++ mono/Makefile.in Mon Sep 12 00:06:09 2005
-@@ -466,11 +466,11 @@
+--- mono/Makefile.in.orig 2015-06-02 10:27:29 UTC
++++ mono/Makefile.in
+@@ -530,11 +530,11 @@ $(ASSEMBLY): $(build_sources) generated-
install-data-local:
@if test -n '$(TARGET)'; then \
if test -n '$(DESTDIR)'; then \
diff --git a/mail/gmime2/files/patch-tests__test-mbox.c b/mail/gmime2/files/patch-tests__test-mbox.c
index bba86048372d..708edeb5693a 100644
--- a/mail/gmime2/files/patch-tests__test-mbox.c
+++ b/mail/gmime2/files/patch-tests__test-mbox.c
@@ -1,10 +1,10 @@
---- tests/test-mbox.c.orig Mon Feb 12 15:48:22 2007
-+++ tests/test-mbox.c Mon Feb 12 15:48:54 2007
-@@ -26,6 +26,7 @@
+--- tests/test-mbox.c.orig 2011-03-07 18:09:21 UTC
++++ tests/test-mbox.c
+@@ -32,6 +32,7 @@
#include <fcntl.h>
#include <time.h>
+#include <config.h>
#include <gmime/gmime.h>
- #ifndef G_OS_WIN32
+ #include "testsuite.h"
diff --git a/mail/gmime2/files/patch-tests__test-mime.c b/mail/gmime2/files/patch-tests__test-mime.c
index 35067da0afa6..879289e78880 100644
--- a/mail/gmime2/files/patch-tests__test-mime.c
+++ b/mail/gmime2/files/patch-tests__test-mime.c
@@ -1,10 +1,10 @@
---- tests/test-mime.c.orig Mon Feb 12 15:48:32 2007
-+++ tests/test-mime.c Mon Feb 12 15:49:04 2007
-@@ -21,6 +21,7 @@
- #include <stdio.h>
+--- tests/test-mime.c.orig 2011-03-07 18:09:21 UTC
++++ tests/test-mime.c
+@@ -27,6 +27,7 @@
#include <string.h>
+ #include <ctype.h>
+#include <config.h>
#include <gmime/gmime.h>
- #ifndef G_OS_WIN32
+ #include "testsuite.h"
diff --git a/mail/gmime2/files/patch-tests__test-parser.c b/mail/gmime2/files/patch-tests__test-parser.c
index a408ff684cfe..56960337fef3 100644
--- a/mail/gmime2/files/patch-tests__test-parser.c
+++ b/mail/gmime2/files/patch-tests__test-parser.c
@@ -1,6 +1,6 @@
---- tests/test-parser.c.orig Mon Feb 12 15:48:38 2007
-+++ tests/test-parser.c Mon Feb 12 15:49:14 2007
-@@ -26,6 +26,7 @@
+--- tests/test-parser.c.orig 2011-03-07 18:09:21 UTC
++++ tests/test-parser.c
+@@ -30,6 +30,7 @@
#include <fcntl.h>
#include <time.h>