aboutsummaryrefslogtreecommitdiff
path: root/mail/gmime2
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2007-02-12 17:57:15 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2007-02-12 17:57:15 +0000
commitd083e01edf1622e45a2ad304629e3dbbdcfc3dcd (patch)
treef828e5c93dd37c4ef9957caa9cc7bd49529c4483 /mail/gmime2
parent4d64dc0f18a5f2aa5b512abe8caea528ba9976d0 (diff)
- Update to 2.2.4
- Fix unnecessary print [1] PR: 106813 [1] Submitted by: Larry Rosenman <ler___lerctr.org> [1]
Notes
Notes: svn path=/head/; revision=185025
Diffstat (limited to 'mail/gmime2')
-rw-r--r--mail/gmime2/Makefile2
-rw-r--r--mail/gmime2/distinfo6
-rw-r--r--mail/gmime2/files/patch-gmime__gmime-utils.c11
-rw-r--r--mail/gmime2/files/patch-tests__test-mbox.c10
-rw-r--r--mail/gmime2/files/patch-tests__test-mime.c10
-rw-r--r--mail/gmime2/files/patch-tests__test-parser.c10
6 files changed, 45 insertions, 4 deletions
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index 52051a29369e..3b8b5f6d8a6a 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gmime
-PORTVERSION= 2.2.3
+PORTVERSION= 2.2.4
PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= http://spruce.sourceforge.net/gmime/sources/v${PORTVERSION:C/([0-9]\.[0-9]).*/\1/}/
diff --git a/mail/gmime2/distinfo b/mail/gmime2/distinfo
index f07137134862..04464e2e8add 100644
--- a/mail/gmime2/distinfo
+++ b/mail/gmime2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gmime-2.2.3.tar.gz) = 0c48ece8b65955db8e7d89c171de974b
-SHA256 (gmime-2.2.3.tar.gz) = 285f4ab080ce2fd11a52a181e682a64ba26cb1c814dc5829c553ecc0efc95126
-SIZE (gmime-2.2.3.tar.gz) = 927173
+MD5 (gmime-2.2.4.tar.gz) = dd86578d15138596fae2bfe04d392f33
+SHA256 (gmime-2.2.4.tar.gz) = 7dcff1a0b3e160e70307e201581d1f08d226979d01cb5440bb1fdb0d70a50c9f
+SIZE (gmime-2.2.4.tar.gz) = 933842
diff --git a/mail/gmime2/files/patch-gmime__gmime-utils.c b/mail/gmime2/files/patch-gmime__gmime-utils.c
new file mode 100644
index 000000000000..e43b7eb46eb4
--- /dev/null
+++ b/mail/gmime2/files/patch-gmime__gmime-utils.c
@@ -0,0 +1,11 @@
+--- gmime/gmime-utils.c.orig Mon Feb 12 10:53:03 2007
++++ gmime/gmime-utils.c Mon Feb 12 10:53:21 2007
+@@ -646,7 +646,7 @@
+ goto next;
+ } else if (!tm.tm_year) {
+ if ((n = get_year (token->start, token->len)) != -1) {
+- printf ("2-digit year; ");
++ d(printf ("2-digit year; "));
+ tm.tm_year = n - 1900;
+ }
+ goto next;
diff --git a/mail/gmime2/files/patch-tests__test-mbox.c b/mail/gmime2/files/patch-tests__test-mbox.c
new file mode 100644
index 000000000000..bba86048372d
--- /dev/null
+++ b/mail/gmime2/files/patch-tests__test-mbox.c
@@ -0,0 +1,10 @@
+--- tests/test-mbox.c.orig Mon Feb 12 15:48:22 2007
++++ tests/test-mbox.c Mon Feb 12 15:48:54 2007
+@@ -26,6 +26,7 @@
+ #include <fcntl.h>
+ #include <time.h>
+
++#include <config.h>
+ #include <gmime/gmime.h>
+
+ #ifndef G_OS_WIN32
diff --git a/mail/gmime2/files/patch-tests__test-mime.c b/mail/gmime2/files/patch-tests__test-mime.c
new file mode 100644
index 000000000000..35067da0afa6
--- /dev/null
+++ b/mail/gmime2/files/patch-tests__test-mime.c
@@ -0,0 +1,10 @@
+--- tests/test-mime.c.orig Mon Feb 12 15:48:32 2007
++++ tests/test-mime.c Mon Feb 12 15:49:04 2007
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+
++#include <config.h>
+ #include <gmime/gmime.h>
+
+ #ifndef G_OS_WIN32
diff --git a/mail/gmime2/files/patch-tests__test-parser.c b/mail/gmime2/files/patch-tests__test-parser.c
new file mode 100644
index 000000000000..a408ff684cfe
--- /dev/null
+++ b/mail/gmime2/files/patch-tests__test-parser.c
@@ -0,0 +1,10 @@
+--- tests/test-parser.c.orig Mon Feb 12 15:48:38 2007
++++ tests/test-parser.c Mon Feb 12 15:49:14 2007
+@@ -26,6 +26,7 @@
+ #include <fcntl.h>
+ #include <time.h>
+
++#include <config.h>
+ #include <gmime/gmime.h>
+
+ #ifndef G_OS_WIN32