aboutsummaryrefslogtreecommitdiff
path: root/mail/gnome-gmail-notifier
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /mail/gnome-gmail-notifier
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'mail/gnome-gmail-notifier')
-rw-r--r--mail/gnome-gmail-notifier/Makefile4
-rw-r--r--mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c16
2 files changed, 18 insertions, 2 deletions
diff --git a/mail/gnome-gmail-notifier/Makefile b/mail/gnome-gmail-notifier/Makefile
index 053a90b69c10..fafe71278a6b 100644
--- a/mail/gnome-gmail-notifier/Makefile
+++ b/mail/gnome-gmail-notifier/Makefile
@@ -7,14 +7,14 @@
PORTNAME= gnome-gmail-notifier
PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail deskutils
MASTER_SITES= GOOGLE_CODE
MAINTAINER= avl@FreeBSD.org
COMMENT= A Gmail Inbox Monitor for the GNOME2 desktop
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
soup-2.4:${PORTSDIR}/devel/libsoup \
gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
diff --git a/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c b/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c
new file mode 100644
index 000000000000..59bae8fbc5f3
--- /dev/null
+++ b/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c
@@ -0,0 +1,16 @@
+--- src/ggn-icon.c.orig 2011-08-16 13:36:23.000000000 +0200
++++ src/ggn-icon.c 2011-08-16 13:37:27.000000000 +0200
+@@ -566,12 +566,7 @@ gpointer ggn_icon_show_notification_thre
+ /* create a new notification. */
+ icon->priv->note = notify_notification_new (icon->priv->title,
+ icon->priv->summary,
+- icon->priv->icon_file,
+- NULL);
+-
+- /* attach the notification to our icon. */
+- notify_notification_attach_to_status_icon (icon->priv->note,
+- icon->priv->icon);
++ icon->priv->icon_file);
+
+ /* set the notification timeout. */
+ notify_notification_set_timeout (icon->priv->note, (4 * 1000));