aboutsummaryrefslogtreecommitdiff
path: root/mail/grepmail/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-16 14:09:28 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-16 14:09:28 +0000
commit624e583e50b094573045c0cd48ba7dbe732ecbbb (patch)
tree62fbf650e1da608cef8cc2d58b0eb30a75c080a7 /mail/grepmail/Makefile
parentbfffba5d1ff07eec71d9f1daf4a57b8cd24a70f5 (diff)
downloadports-624e583e50b094573045c0cd48ba7dbe732ecbbb.tar.gz
ports-624e583e50b094573045c0cd48ba7dbe732ecbbb.zip
Notes
Diffstat (limited to 'mail/grepmail/Makefile')
-rw-r--r--mail/grepmail/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/mail/grepmail/Makefile b/mail/grepmail/Makefile
index b3a04329ae66..cfad8ebc1060 100644
--- a/mail/grepmail/Makefile
+++ b/mail/grepmail/Makefile
@@ -6,25 +6,24 @@
#
PORTNAME= grepmail
-PORTVERSION= 4.31
+PORTVERSION= 4.40
CATEGORIES= mail
MASTER_SITES= http://download.sourceforge.net/grepmail/
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+
MAINTAINER= jedgar@FreeBSD.org
USE_PERL5= yes
-NO_BUILD= yes
-POD2MAN?= /usr/bin/pod2man
MAN1= grepmail.1
do-configure:
- @${PERL} -pi.orig -e 's|_PERL_|${PERL}|' ${WRKSRC}/grepmail.DP
- @cd ${WRKSRC} && ${CP} grepmail.DP grepmail
- @cd ${WRKSRC} && ${POD2MAN} grepmail > grepmail.1
+ @cd ${WRKSRC} && ${PERL} Makefile.PL
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/grepmail ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/grepmail.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/grepmail.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>