aboutsummaryrefslogtreecommitdiff
path: root/mail/greyfix/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-06-14 20:54:43 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-06-14 20:54:43 +0000
commita08565f4a02eff57da7edf51e5473195ca593206 (patch)
tree9fbcc6f093ded3c580b7e8336f51e0ef36acb990 /mail/greyfix/Makefile
parent0b8f294fc3e75fa222ca93fa2f4b33623535f59e (diff)
Notes
Diffstat (limited to 'mail/greyfix/Makefile')
-rw-r--r--mail/greyfix/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/mail/greyfix/Makefile b/mail/greyfix/Makefile
index 3ea3d41064ef..e2257b4f08f0 100644
--- a/mail/greyfix/Makefile
+++ b/mail/greyfix/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= greyfix
-PORTVERSION= 0.3.9
+PORTVERSION= 0.4.0
CATEGORIES= mail
-MASTER_SITES= http://www.kim-minh.com/pub/greyfix/
+MASTER_SITES= http://www.kim-minh.com/pub/greyfix/ \
+ http://stereochro.me/distfiles/
MAINTAINER= k@stereochro.me
-COMMENT= A greylisting policy daemon for Postfix
+COMMENT= Greylisting policy daemon for Postfix
SUB_FILES= pkg-message
-USE_BDB= yes
+USE_BDB= 5+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-berkeleydb-libdir=${BDB_LIB_DIR} \
+CONFIGURE_ARGS+=--with-berkeleydb-libdir=${BDB_LIB_DIR} \
--with-berkeleydb-includedir=${BDB_INCLUDE_DIR} \
--localstatedir=/var
@@ -23,7 +24,8 @@ post-patch:
${WRKSRC}/Makefile.in
do-install:
+ @${MKDIR} ${STAGEDIR}/var/db/greyfix
${INSTALL_PROGRAM} ${WRKSRC}/greyfix ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL} -o nobody -m 700 -d ${STAGEDIR}/var/db/greyfix
+ ${INSTALL_MAN} ${FILESDIR}/greyfix.8 ${STAGEDIR}${MAN1PREFIX}/man/man8/
.include <bsd.port.mk>