aboutsummaryrefslogtreecommitdiff
path: root/mail/greylite/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-19 12:42:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-19 12:42:50 +0000
commitcc70c8ad2c644bb88f695be13c36c740ee3a92e9 (patch)
treef4175ad6eba5d416dc0d3b84dff535ca108db7ca /mail/greylite/Makefile
parentefcf49406fcf4774734138e1a28651df3f0c348d (diff)
downloadports-cc70c8ad2c644bb88f695be13c36c740ee3a92e9.tar.gz
ports-cc70c8ad2c644bb88f695be13c36c740ee3a92e9.zip
Notes
Diffstat (limited to 'mail/greylite/Makefile')
-rw-r--r--mail/greylite/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
new file mode 100644
index 000000000000..6a9ab963170e
--- /dev/null
+++ b/mail/greylite/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: greylite
+# Date created: 2007-12-11
+# Whom: Mij <mij@bitchx.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= greylite
+DISTVERSION= 1.3
+CATEGORIES= mail
+MASTER_SITES= http://mij.oltrelinux.com/net/greylite/
+
+MAINTAINER= mij@bitchx.it
+COMMENT= An efficient greylisting module for qmail
+
+USE_BZIP2= yes
+USE_SQLITE= 3
+PLIST_FILES= bin/greylite
+
+MAN8= greylite.8
+MANCOMPRESSED= yes
+
+OPTIONS= GEOIP "Enable support for GeoIP in suspicion rules" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GEOIP)
+LIB_DEPENDS+= GeoIP:$(PORTSDIR)/net/GeoIP
+MAKE_ARGS+= WITH_GEOIP=yep
+.endif
+
+post-patch:
+ ${CP} ${WRKSRC}/Makefile.bsdmake ${WRKSRC}/Makefile
+
+do-build:
+ $(MAKE) -C $(WRKSRC) $(MAKE_ARGS)
+
+post-install:
+ @$(CAT) pkg-message
+
+.include <bsd.port.post.mk>