aboutsummaryrefslogtreecommitdiff
path: root/mail/gubby/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-02-27 06:54:13 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-02-27 06:54:13 +0000
commit8b378cfb5058b1e6289b106f41da73896c392391 (patch)
treedacf681bccf5e88c2d23b74d1a1ba10ed1d05011 /mail/gubby/Makefile
parent038b4687e1b0bb198e759e0f4d8a406e974a7bd4 (diff)
downloadports-8b378cfb5058b1e6289b106f41da73896c392391.tar.gz
ports-8b378cfb5058b1e6289b106f41da73896c392391.zip
Notes
Diffstat (limited to 'mail/gubby/Makefile')
-rw-r--r--mail/gubby/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/gubby/Makefile b/mail/gubby/Makefile
index 8d9fca5f2416..03d7833733f4 100644
--- a/mail/gubby/Makefile
+++ b/mail/gubby/Makefile
@@ -7,13 +7,17 @@
#
PORTNAME= gubby
-PORTVERSION= 0.3.2
+PORTVERSION= 0.4.2
CATEGORIES= mail
-MASTER_SITES= http://sublevel3.org/~csl/gubby/dist/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= mich@freebsdcluster.org
COMMENT= A program showing where new mail has been placed
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
LDFLAGS+= -lncurses -ltermcap
CFLAGS+= -felide-constructors -fno-default-inline
@@ -23,9 +27,12 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gubby ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${PREFIX}/man/man1
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}/README
.endif
+MAN1= gubby.1
.include <bsd.port.mk>