aboutsummaryrefslogtreecommitdiff
path: root/mail/hashcash/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-19 03:36:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-19 03:36:42 +0000
commitd5813fda66ccfe9f23320b1e1e5bd855ac588241 (patch)
tree963f8365ded2dcb28a370ee664a314a18133b765 /mail/hashcash/Makefile
parent750d38b4e82270d9bcadbc89db89a485df7e55dc (diff)
downloadports-d5813fda66ccfe9f23320b1e1e5bd855ac588241.tar.gz
ports-d5813fda66ccfe9f23320b1e1e5bd855ac588241.zip
Notes
Diffstat (limited to 'mail/hashcash/Makefile')
-rw-r--r--mail/hashcash/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/mail/hashcash/Makefile b/mail/hashcash/Makefile
index 8481b2eb19dc..5ee7a6ce606b 100644
--- a/mail/hashcash/Makefile
+++ b/mail/hashcash/Makefile
@@ -10,16 +10,29 @@ EXTRACT_SUFX= .tgz
MAINTAINER= chalpin@cs.wisc.edu
COMMENT= Anti-spam / denial of service counter-measure tool
+LICENSE=BSD LGPL21 GPLv2
+LICENSE_COMB=dual
+
+# Also CPL: https://en.wikipedia.org/wiki/Common_Public_License
+# and Public Domain
+
MAN1= hashcash.1 sha1-hashcash.1
PLIST_FILES= bin/hashcash bin/sha1
+PLIST_FILES+= man/man1/hashcash.1.gz
+PLIST_FILES+= man/man1/sha1-hashcash.1.gz
+
PORTDOCS= CHANGELOG LICENSE README
ALL_TARGET= generic
-NO_STAGE= yes
-.if defined(NOPORTDOCS)
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
+
+.include <bsd.port.options.mk>
+
+.if !${PORT_OPTIONS:MDOCS}
post-patch:
${REINPLACE_CMD} -e '/DOC_INSTALL_PATH/d' ${WRKSRC}/Makefile
+
.endif
.include <bsd.port.mk>