aboutsummaryrefslogtreecommitdiff
path: root/mail/horde-ingo
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-17 14:00:19 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-17 14:00:19 +0000
commitb96b84ff6bd1d83282184c5f2a8899b44a4c27a7 (patch)
treefc49de33e72daa28b55284a6c02dfc336e40ede1 /mail/horde-ingo
parentedfb9be3b2a50a0127d035c3f3f0afe1d4b5396a (diff)
downloadports-b96b84ff6bd1d83282184c5f2a8899b44a4c27a7.tar.gz
ports-b96b84ff6bd1d83282184c5f2a8899b44a4c27a7.zip
Notes
Diffstat (limited to 'mail/horde-ingo')
-rw-r--r--mail/horde-ingo/Makefile3
-rw-r--r--mail/horde-ingo/files/patch-lib_Script_procmail.php22
2 files changed, 24 insertions, 1 deletions
diff --git a/mail/horde-ingo/Makefile b/mail/horde-ingo/Makefile
index 66894f273094..4aa1b0a8c79d 100644
--- a/mail/horde-ingo/Makefile
+++ b/mail/horde-ingo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ingo
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
ftp://ftp.planetmirror.com/pub/horde/ingo/ \
@@ -20,7 +21,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= shaun@FreeBSD.org
-COMMENT= Horde\'s email-filter management application
+COMMENT= Horde's email-filter management application
#-----------------------------------------------------------------------
# You may define this option:
diff --git a/mail/horde-ingo/files/patch-lib_Script_procmail.php b/mail/horde-ingo/files/patch-lib_Script_procmail.php
new file mode 100644
index 000000000000..b9a052708819
--- /dev/null
+++ b/mail/horde-ingo/files/patch-lib_Script_procmail.php
@@ -0,0 +1,22 @@
+--- lib/Script/procmail.php.orig Tue Jan 31 20:00:25 2006
++++ lib/Script/procmail.php Thu Aug 17 14:52:45 2006
+@@ -427,9 +427,16 @@
+ $this->_action[] = '{';
+ foreach ($params['action-value']['addresses'] as $address) {
+ if (!empty($address)) {
+- $this->_action[] = ' FILEDATE=`ls -lcn --time-style=+%s \'.vacation.' . $address
+- . '\' | awk \'{ print $6 + ('
+- . $days * 86400 . ') }\'`';
++/***** This bit does not work with FreeBSD.
++ * $this->_action[] = ' FILEDATE=`ls -lcn --time-style=+%s \'.vacation.' . $address
++ * . '\' | awk \'{ print $6 + ('
++ * . $days * 86400 . ') }\'`';
++ *
++ */
++ $this->_action[] = ' FDATE=`ls -lcnT \'.vacation.' . $address
++ . '\' 2> /dev/null | awk \'{ print $6, $7, $8, $9; }\'`';
++ $this->_action[] = ' FILEDATE=`date -j -f "%b %d %H:%M:%S %Y" "$FDATE" +%s '
++ . ' | awk \'{ print $1 + (' . $days * 86400 . ') }\'`';
+ $this->_action[] = ' DATE=`date +%s`';
+ $this->_action[] = ' DUMMY=`test $FILEDATE -le $DATE'
+ .' && rm \'.vacation.' . $address .'\'`';