aboutsummaryrefslogtreecommitdiff
path: root/mail/horde-mimp
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 23:42:31 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-08 23:42:31 +0000
commit1e0d8c9112e8493a5f7edfd1134a422c3e3efac3 (patch)
tree8195bcc94557ed871bb3862c71b9314dc2c43bd8 /mail/horde-mimp
parent3e50ab625e240bab15b5babee4112f1f654cae5d (diff)
downloadports-1e0d8c9112e8493a5f7edfd1134a422c3e3efac3.tar.gz
ports-1e0d8c9112e8493a5f7edfd1134a422c3e3efac3.zip
Notes
Diffstat (limited to 'mail/horde-mimp')
-rw-r--r--mail/horde-mimp/Makefile103
-rw-r--r--mail/horde-mimp/files/httpd.conf.mimp31
-rw-r--r--mail/horde-mimp/files/pkg-deinstall.in23
-rw-r--r--mail/horde-mimp/files/pkg-install.in23
-rw-r--r--mail/horde-mimp/files/pkg-message.in6
-rw-r--r--mail/horde-mimp/pkg-plist237
6 files changed, 123 insertions, 300 deletions
diff --git a/mail/horde-mimp/Makefile b/mail/horde-mimp/Makefile
index 017f37710359..c8abd67b2b31 100644
--- a/mail/horde-mimp/Makefile
+++ b/mail/horde-mimp/Makefile
@@ -7,9 +7,7 @@
PORTNAME= mimp
PORTVERSION= 1.0.1
-DISTVERSIONPREFIX= h3-
CATEGORIES= mail www
-MASTER_SITES= HORDE
MAINTAINER= beech@alaskaparadise.com
COMMENT= Mobile webmail system
@@ -28,21 +26,6 @@ COMMENT= Mobile webmail system
# - WITHOUT_SSL if you have not installed c-client WITH_SSL;
#
# - WITH_VALID_CERT if you own a valid SSL certificate;
-#
-# - WITH_IMAPSERVER if you want to depend on an IMAP server;
-#
-# or you can select to work with one of these servers:
-#
-# - WITH_CYRUS-IMAPD MIMP will work with cyrus-imapd;
-#
-# - WITH_IMAP-UW MIMP will work with imap-uw;
-#
-# - WITH_DOVECOT MIMP will work with dovecot;
-#
-# - WITH_COURIER-IMAP MIMP will work with courier-imap.
-#
-# These choices are mutually exclusive, and imap-uw is the default.
-#
#-----------------------------------------------------------------------
RUN_DEPENDS+= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
@@ -51,74 +34,18 @@ USE_PHP= imap
. if !defined(WITHOUT_LDAP)
USE_PHP+= ldap
. endif
-
-RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
-
.if !defined(WITHOUT_SMIME)
USE_PHP+= openssl
.endif
-
.if !defined(NOCRYPT)
RUN_DEPENDS+= ${LOCALBASE}/bin/gpgv:${PORTSDIR}/security/gnupg1
.endif
-NO_BUILD= yes
-USE_APACHE= 1.3+ # needed to test APACHE_VERSION
+USE_HORDE= base
USE_GETTEXT= yes
-REINPLACE_ARGS= -i.beforeMIMP
-
PORTDOCS= README CHANGES CREDITS INSTALL RELEASE_NOTES
-CONFFILE= filter.txt header.php menu.php mime_drivers.php motd.php \
- prefs.php servers.php trailer.txt conf.xml .htaccess
-SUB_DIRS= config lib locale po templates themes
-
-LHORDEDIR?= www/horde
-LMIMPDIR= ${LHORDEDIR}/mimp
-PEARDIR?= ${LOCALBASE}/share/pear
-
-PLIST_SUB= MIMPDIR=${LMIMPDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-install pkg-deinstall
-SUB_LIST= MIMPDIR=${MIMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
-
-MIMPDIR= ${PREFIX}/${LMIMPDIR}
-CONFDIR= ${MIMPDIR}/config
-
-HOSTNAME?= `/bin/hostname`
-SERVOS?= ${OPSYS}-${OSREL}
-
-PORTREV_H?= ${LOCALBASE}/include/c-client/portrevision.h
-
-PATCH2RM= prefs.php.dist.orig servers.php.dist.orig
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_IMAPSERVER)
-. if defined(WITH_IMAP-UW) || exists(${LOCALBASE}/libexec/imapd)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw
-. elif defined(WITH_CYRUS-IMAPD) || exists(${LOCALBASE}/cyrus/bin/master)
-RUN_DEPENDS+= ${LOCALBASE}/cyrus/bin/master:${PORTSDIR}/mail/cyrus-imapd23
-. elif defined(WITH_COURIER-IMAP) || exists(${LOCALBASE}/bin/deliverquota)
-RUN_DEPENDS+= ${LOCALBASE}/bin/deliverquota:${PORTSDIR}/mail/courier-imap
-. elif defined(WITH_DOVECOT) || exists(${LOCALBASE}/libexec/dovecot/imap)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/dovecot/imap:${PORTSDIR}/mail/dovecot
-. else
-RUN_DEPENDS+= ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw
-. endif
-.endif
-
-.if ${APACHE_VERSION} >= 20
-HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
-.else
-HORDE_INC= ${LOCALBASE}/etc/horde/
-.endif
-
-post-extract:
- @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
pre-configure:
- @${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
.if !defined(NOCRYPT)
@${REINPLACE_CMD} -e "s:%%GPG%%:${LOCALBASE}/bin/gpg:" \
${WRKSRC}/config/conf.xml
@@ -142,8 +69,6 @@ pre-configure:
${WRKSRC}/config/servers.php.dist
. endif
.endif
- @${SED} -e "s:/home/httpd/html/horde/mimp:${MIMPDIR}:" \
- ${FILESDIR}/httpd.conf.mimp > ${WRKDIR}/httpd-mimp.conf
pre-install:
.if !defined(BATCH) && !defined(WITHOUT_SSL)
@@ -154,28 +79,6 @@ pre-install:
${FALSE} ; \
fi
.endif
-.for fc in ${PATCH2RM}
- @${RM} ${WRKSRC}/config/${fc}
-.endfor
-
-do-install:
- @${INSTALL} -d ${MIMPDIR}/
- @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${MIMPDIR}/
- @${CP} -p ${WRKSRC}/*.php ${MIMPDIR}/
- @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${INSTALL_DATA} ${WRKDIR}/httpd-mimp.conf ${HORDE_INC}/
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MIMPDIR}/
- @${CHMOD} -R o-rwx ${CONFDIR}/
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
+.include <bsd.port.mk>
diff --git a/mail/horde-mimp/files/httpd.conf.mimp b/mail/horde-mimp/files/httpd.conf.mimp
deleted file mode 100644
index 0a6aadc8a2cc..000000000000
--- a/mail/horde-mimp/files/httpd.conf.mimp
+++ /dev/null
@@ -1,31 +0,0 @@
-# This is included in Apache's httpd.conf for MIMP
-#
-# For security, don't serve pages from the MIMP configuration and
-# library directories.
-#
-<Directory "/home/httpd/html/horde/mimp/config">
- order deny,allow
- deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/mimp/lib">
- order deny,allow
- deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/mimp/locale">
- order deny,allow
- deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/mimp/po">
- order deny,allow
- deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/mimp/scripts">
- order deny,allow
- deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/mimp/templates">
- order deny,allow
- deny from all
-</Directory>
-# End of MIMP configuration ================
-
diff --git a/mail/horde-mimp/files/pkg-deinstall.in b/mail/horde-mimp/files/pkg-deinstall.in
deleted file mode 100644
index 7f721dba2f9a..000000000000
--- a/mail/horde-mimp/files/pkg-deinstall.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%MIMPDIR%%/config/*php %%MIMPDIR%%/config/*txt`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, delete it
- rm -f $cf
- ;;
- 1) # config file has been updated, leave it alone
- ;;
- *) # not found?
- ;;
- esac
- done
-fi
diff --git a/mail/horde-mimp/files/pkg-install.in b/mail/horde-mimp/files/pkg-install.in
deleted file mode 100644
index 6268cfb52df6..000000000000
--- a/mail/horde-mimp/files/pkg-install.in
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD:
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-case $2 in
- PRE-INSTALL)
- ;;
-
- POST-INSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- # Copy over sample config files unless they already exist
-
- for cf in `ls %%MIMPDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
- if [ ! -f $cf ]; then
- cp -p $cf.dist $cf
- fi
- done
- fi
- ;;
-esac
diff --git a/mail/horde-mimp/files/pkg-message.in b/mail/horde-mimp/files/pkg-message.in
index 0710c978e6d5..20c7c869de8d 100644
--- a/mail/horde-mimp/files/pkg-message.in
+++ b/mail/horde-mimp/files/pkg-message.in
@@ -1,12 +1,12 @@
************************************************************************
-MIMP has been installed in %%MIMPDIR%% with your blank
+MIMP has been installed in %%HORDIR%% with your blank
configuration files.
Horde must be configured and the tables created; if not, see
-`pkg_info -D -x horde'.
+`pkg_info -Dx horde-base'.
Then, you might have to tune the configuration files located in
-%%CONFDIR%%/, specially the file servers.php.
+%%HORCFG%%/, specially the file servers.php.
Then, you must login to Horde as a Horde Administrator to finish the
configuration. Please read %%DOCSDIR%%/INSTALL.
diff --git a/mail/horde-mimp/pkg-plist b/mail/horde-mimp/pkg-plist
index 9009f3448350..55d92b55df58 100644
--- a/mail/horde-mimp/pkg-plist
+++ b/mail/horde-mimp/pkg-plist
@@ -1,120 +1,117 @@
-%%MIMPDIR%%/compose.php
-%%MIMPDIR%%/config/.htaccess
-%%MIMPDIR%%/config/conf.xml
-%%MIMPDIR%%/config/filter.txt.dist
-%%MIMPDIR%%/config/header.php.dist
-%%MIMPDIR%%/config/menu.php.dist
-%%MIMPDIR%%/config/mime_drivers.php.dist
-%%MIMPDIR%%/config/motd.php.dist
-%%MIMPDIR%%/config/prefs.php.dist
-%%MIMPDIR%%/config/servers.php.dist
-%%MIMPDIR%%/config/trailer.txt.dist
-%%MIMPDIR%%/config/conf.xml.beforeMIMP
-%%MIMPDIR%%/config/servers.php.dist.beforeMIMP
-%%MIMPDIR%%/folders.php
-%%MIMPDIR%%/index.php
-%%MIMPDIR%%/lib/Auth/mimp.php
-%%MIMPDIR%%/lib/base.php
-%%MIMPDIR%%/lib/Compose.php
-%%MIMPDIR%%/lib/Folder.php
-%%MIMPDIR%%/lib/IMAP.php
-%%MIMPDIR%%/lib/IMAP/Client.php
-%%MIMPDIR%%/lib/IMAP/Sort.php
-%%MIMPDIR%%/lib/IMAP/Tree.php
-%%MIMPDIR%%/lib/Identity/mimp.php
-%%MIMPDIR%%/lib/MIME/Contents.php
-%%MIMPDIR%%/lib/MIME/Headers.php
-%%MIMPDIR%%/lib/MIME/Viewer/alternative.php
-%%MIMPDIR%%/lib/MIME/Viewer/html.php
-%%MIMPDIR%%/lib/MIME/Viewer/multipart.php
-%%MIMPDIR%%/lib/MIME/Viewer/plain.php
-%%MIMPDIR%%/lib/MIME/Viewer/related.php
-%%MIMPDIR%%/lib/MIME/Headers.php.beforeMIMP
-%%MIMPDIR%%/lib/Mailbox.php
-%%MIMPDIR%%/lib/Message.php
-%%MIMPDIR%%/lib/MIMP.php
-%%MIMPDIR%%/lib/Session.php
-%%MIMPDIR%%/lib/api.php
-%%MIMPDIR%%/lib/prefs.php
-%%MIMPDIR%%/lib/version.php
-%%MIMPDIR%%/locale/ca_ES/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/de_DE/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/es_ES/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/fi_FI/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/fr_FR/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/hu_HU/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/it_IT/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/lt_LT/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/nl_NL/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/pt_PT/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/locale/ro_RO/LC_MESSAGES/mimp.mo
-%%MIMPDIR%%/login.php
-%%MIMPDIR%%/mailbox.php
-%%MIMPDIR%%/message.php
-%%MIMPDIR%%/po/README
-%%MIMPDIR%%/po/mimp.pot
-%%MIMPDIR%%/po/ca_ES.po
-%%MIMPDIR%%/po/de_DE.po
-%%MIMPDIR%%/po/es_ES.po
-%%MIMPDIR%%/po/fi_FI.po
-%%MIMPDIR%%/po/fr_FR.po
-%%MIMPDIR%%/po/hu_HU.po
-%%MIMPDIR%%/po/it_IT.po
-%%MIMPDIR%%/po/lt_LT.po
-%%MIMPDIR%%/po/nl_NL.po
-%%MIMPDIR%%/po/pt_PT.po
-%%MIMPDIR%%/po/ro_RO.po
-%%MIMPDIR%%/redirect.php
-%%MIMPDIR%%/templates/common-header.inc
-%%MIMPDIR%%/templates/compose/compose.inc
-%%MIMPDIR%%/templates/compose/redirect.inc
-%%MIMPDIR%%/templates/index/notconfigured.inc
-%%MIMPDIR%%/templates/login/login.inc
-%%MIMPDIR%%/templates/mailbox/mailbox.inc
-%%MIMPDIR%%/templates/prefs/sentmailselect.inc
-%%MIMPDIR%%/test.php
-%%MIMPDIR%%/themes/graphics/favicon.ico
-%%MIMPDIR%%/themes/graphics/mimp.png
-%%MIMPDIR%%/themes/graphics/horde-power2.png
-%%MIMPDIR%%/themes/graphics/horde-power2.wbmp
-%%HORDE_INC%%httpd-mimp.conf
-@dirrm %%MIMPDIR%%/themes/graphics
-@dirrm %%MIMPDIR%%/themes
-@dirrm %%MIMPDIR%%/templates/prefs
-@dirrm %%MIMPDIR%%/templates/mailbox
-@dirrm %%MIMPDIR%%/templates/login
-@dirrm %%MIMPDIR%%/templates/index
-@dirrm %%MIMPDIR%%/templates/compose
-@dirrm %%MIMPDIR%%/templates
-@dirrm %%MIMPDIR%%/po
-@dirrm %%MIMPDIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/ro_RO
-@dirrm %%MIMPDIR%%/locale/pt_PT/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/pt_PT
-@dirrm %%MIMPDIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/nl_NL
-@dirrm %%MIMPDIR%%/locale/lt_LT/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/lt_LT
-@dirrm %%MIMPDIR%%/locale/it_IT/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/it_IT
-@dirrm %%MIMPDIR%%/locale/hu_HU/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/hu_HU
-@dirrm %%MIMPDIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/fr_FR
-@dirrm %%MIMPDIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/fi_FI
-@dirrm %%MIMPDIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/es_ES
-@dirrm %%MIMPDIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/de_DE
-@dirrm %%MIMPDIR%%/locale/ca_ES/LC_MESSAGES
-@dirrm %%MIMPDIR%%/locale/ca_ES
-@dirrm %%MIMPDIR%%/locale
-@dirrm %%MIMPDIR%%/lib/MIME/Viewer
-@dirrm %%MIMPDIR%%/lib/MIME
-@dirrm %%MIMPDIR%%/lib/Identity
-@dirrm %%MIMPDIR%%/lib/IMAP
-@dirrm %%MIMPDIR%%/lib/Auth
-@dirrm %%MIMPDIR%%/lib
-@dirrmtry %%MIMPDIR%%/config
-@dirrmtry %%MIMPDIR%%
+%%HORDIR%%/compose.php
+%%HORDIR%%/config/.htaccess
+%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/filter.txt.dist
+%%HORDIR%%/config/header.php.dist
+%%HORDIR%%/config/menu.php.dist
+%%HORDIR%%/config/mime_drivers.php.dist
+%%HORDIR%%/config/motd.php.dist
+%%HORDIR%%/config/prefs.php.dist
+%%HORDIR%%/config/servers.php.dist
+%%HORDIR%%/config/trailer.txt.dist
+%%HORDIR%%/folders.php
+%%HORDIR%%/index.php
+%%HORDIR%%/lib/Auth/mimp.php
+%%HORDIR%%/lib/Compose.php
+%%HORDIR%%/lib/Folder.php
+%%HORDIR%%/lib/IMAP/Client.php
+%%HORDIR%%/lib/IMAP/Sort.php
+%%HORDIR%%/lib/IMAP/Tree.php
+%%HORDIR%%/lib/IMAP.php
+%%HORDIR%%/lib/Identity/mimp.php
+%%HORDIR%%/lib/MIME/Contents.php
+%%HORDIR%%/lib/MIME/Headers.php
+%%HORDIR%%/lib/MIME/Viewer/alternative.php
+%%HORDIR%%/lib/MIME/Viewer/html.php
+%%HORDIR%%/lib/MIME/Viewer/multipart.php
+%%HORDIR%%/lib/MIME/Viewer/plain.php
+%%HORDIR%%/lib/MIME/Viewer/related.php
+%%HORDIR%%/lib/MIMP.php
+%%HORDIR%%/lib/Mailbox.php
+%%HORDIR%%/lib/Message.php
+%%HORDIR%%/lib/Session.php
+%%HORDIR%%/lib/api.php
+%%HORDIR%%/lib/base.php
+%%HORDIR%%/lib/prefs.php
+%%HORDIR%%/lib/version.php
+%%HORDIR%%/locale/ca_ES/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/de_DE/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/es_ES/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/fi_FI/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/fr_FR/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/hu_HU/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/it_IT/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/lt_LT/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/nl_NL/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/pt_PT/LC_MESSAGES/mimp.mo
+%%HORDIR%%/locale/ro_RO/LC_MESSAGES/mimp.mo
+%%HORDIR%%/login.php
+%%HORDIR%%/mailbox.php
+%%HORDIR%%/message.php
+%%HORDIR%%/po/README
+%%HORDIR%%/po/ca_ES.po
+%%HORDIR%%/po/de_DE.po
+%%HORDIR%%/po/es_ES.po
+%%HORDIR%%/po/fi_FI.po
+%%HORDIR%%/po/fr_FR.po
+%%HORDIR%%/po/hu_HU.po
+%%HORDIR%%/po/it_IT.po
+%%HORDIR%%/po/lt_LT.po
+%%HORDIR%%/po/mimp.pot
+%%HORDIR%%/po/nl_NL.po
+%%HORDIR%%/po/pt_PT.po
+%%HORDIR%%/po/ro_RO.po
+%%HORDIR%%/redirect.php
+%%HORDIR%%/templates/common-header.inc
+%%HORDIR%%/templates/compose/compose.inc
+%%HORDIR%%/templates/compose/redirect.inc
+%%HORDIR%%/templates/index/notconfigured.inc
+%%HORDIR%%/templates/login/login.inc
+%%HORDIR%%/templates/mailbox/mailbox.inc
+%%HORDIR%%/templates/prefs/sentmailselect.inc
+%%HORDIR%%/test.php
+%%HORDIR%%/themes/graphics/favicon.ico
+%%HORDIR%%/themes/graphics/horde-power2.png
+%%HORDIR%%/themes/graphics/horde-power2.wbmp
+%%HORDIR%%/themes/graphics/mimp.png
+@dirrmtry %%HORDIR%%/config
+@dirrm %%HORDIR%%/lib/Auth
+@dirrm %%HORDIR%%/lib/IMAP
+@dirrm %%HORDIR%%/lib/Identity
+@dirrm %%HORDIR%%/lib/MIME/Viewer
+@dirrm %%HORDIR%%/lib/MIME
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/locale/ca_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ca_ES
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fr_FR
+@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/hu_HU
+@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/it_IT
+@dirrm %%HORDIR%%/locale/lt_LT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/lt_LT
+@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nl_NL
+@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_PT
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/templates/compose
+@dirrm %%HORDIR%%/templates/index
+@dirrm %%HORDIR%%/templates/login
+@dirrm %%HORDIR%%/templates/mailbox
+@dirrm %%HORDIR%%/templates/prefs
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/graphics
+@dirrm %%HORDIR%%/themes
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%