aboutsummaryrefslogtreecommitdiff
path: root/mail/horde-turba
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-18 07:29:02 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-18 07:29:02 +0000
commitd233d23153a79abe3de1d8486176c4d98ab09947 (patch)
tree8d904b07fa526dd8e87cb6dee568a4229000277e /mail/horde-turba
parent0e4ff235c8f914e857ea9edc6e404904fffd15f0 (diff)
downloadports-d233d23153a79abe3de1d8486176c4d98ab09947.tar.gz
ports-d233d23153a79abe3de1d8486176c4d98ab09947.zip
Notes
Diffstat (limited to 'mail/horde-turba')
-rw-r--r--mail/horde-turba/Makefile66
-rw-r--r--mail/horde-turba/distinfo2
-rw-r--r--mail/horde-turba/pkg-descr6
3 files changed, 74 insertions, 0 deletions
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
new file mode 100644
index 000000000000..0d1e014b007a
--- /dev/null
+++ b/mail/horde-turba/Makefile
@@ -0,0 +1,66 @@
+# Ports collection makefile for: turba
+# Date created: Sat Nov 16, 2001
+# Whom: Thierry Thomas (<thierry@thomas.as>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= turba
+PORTVERSION= 4.0.1
+PKGNAMEPREFIX= horde-
+CATEGORIES= mail www pear
+
+MAINTAINER= horde@FreeBSD.org
+COMMENT= Horde web based address book
+
+LICENSE= AL2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LATEST_LINK= horde4-${PORTNAME}
+
+OPTIONS_DEFINE= FACEBOOK IMSP LDAP
+FACEBOOK_DESC= Support connections with Facebook
+IMSP_DSC= Support IMSP addressbooks
+LDAP_DESC= Support LDAP Addressbooks
+
+USE_PHP= gettext hash json
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ horde \
+ Horde_Auth \
+ Horde_Core \
+ Horde_Data \
+ Horde_Date \
+ Horde_Exception \
+ Horde_Form \
+ Horde_Group \
+ Horde_History \
+ Horde_Icalendar \
+ Horde_Mail \
+ Horde_Mime \
+ Horde_Nls \
+ Horde_Perms \
+ Horde_Prefs \
+ Horde_Serialize \
+ Horde_Share \
+ Horde_Support \
+ Horde_Url \
+ Horde_Util \
+ Horde_View
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MFACEBOOK}
+USE_HORDE_RUN+= Horde_Service_Facebook
+.endif
+
+.if ${PORT_OPTIONS:MIMSP}
+USE_HORDE_RUN+= Horde_Imsp
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_HORDE_RUN+= Horde_Ldap
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/horde-turba/distinfo b/mail/horde-turba/distinfo
new file mode 100644
index 000000000000..de7a2e4fdf0a
--- /dev/null
+++ b/mail/horde-turba/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/turba-4.0.1.tgz) = 31e5161b9f76689a2020bf44307ed78037b69e2e5c0f6b2977aec0991cbb2003
+SIZE (Horde/turba-4.0.1.tgz) = 1977868
diff --git a/mail/horde-turba/pkg-descr b/mail/horde-turba/pkg-descr
new file mode 100644
index 000000000000..bad8d402f189
--- /dev/null
+++ b/mail/horde-turba/pkg-descr
@@ -0,0 +1,6 @@
+Turba is the Horde contact management application. Leveraging the Horde
+framework to provide seamless integration with IMP and other Horde
+applications, it supports storing contacts in SQL, LDAP, Kolab, and IMSP
+address books.
+
+WWW: http://www.horde.org/apps/turba/