aboutsummaryrefslogtreecommitdiff
path: root/mail/horde4-turba
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-03-25 12:41:30 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-03-25 12:41:30 +0000
commitfd66d88088ed16adaf30413cf097a38e44240048 (patch)
tree278449483b8490c3e816dad01b2dfe36c9420dc2 /mail/horde4-turba
parent287c64dc958fc008594899516bcc6c9f01e96240 (diff)
downloadports-fd66d88088ed16adaf30413cf097a38e44240048.tar.gz
ports-fd66d88088ed16adaf30413cf097a38e44240048.zip
Notes
Diffstat (limited to 'mail/horde4-turba')
-rw-r--r--mail/horde4-turba/Makefile33
-rw-r--r--mail/horde4-turba/distinfo6
-rw-r--r--mail/horde4-turba/pkg-plist13
3 files changed, 23 insertions, 29 deletions
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index 20d103b1647c..88d50b10a023 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= turba
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
+DISTVERSIONPREFIX= h3-
CATEGORIES= mail www
MASTER_SITES= HORDE
-DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= beech@alaskaparadise.com
COMMENT= The Horde contact management application
@@ -34,8 +34,8 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_GETTEXT= yes
REINPLACE_ARGS= -i ""
-DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
- docs/LDAP docs/RELEASE_NOTES docs/TODO docs/UPGRADING
+PORTDOCS= README CHANGES CREDITS INSTALL LDAP \
+ RELEASE_NOTES TODO UPGRADING
CONFFILE= attributes.php menu.php mime_drivers.php prefs.php sources.php
SUB_DIRS= config lib locale po scripts templates themes
@@ -66,6 +66,9 @@ HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
HORDE_INC= ${LOCALBASE}/etc/horde
.endif
+post-extract:
+ @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
+
pre-configure:
@${RM} ${WRKSRC}/config/sources.php.dist.orig
@${SED} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
@@ -77,20 +80,16 @@ pre-configure:
.endif
do-install:
- @${MKDIR} ${TURBADIR}
-.for REP in ${SUB_DIRS}
- @${CP} -Rp ${WRKSRC}/${REP} ${TURBADIR}
-.endfor
- @${CP} -p ${WRKSRC}/*.php ${TURBADIR}
-
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${TURBADIR}
- @${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd-turba.conf ${HORDE_INC}
+ @${INSTALL} -d ${TURBADIR}/
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${TURBADIR}/
+ @${CP} -p ${WRKSRC}/*.php ${TURBADIR}/
+ @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
+ @${INSTALL_DATA} ${WRKDIR}/httpd-turba.conf ${HORDE_INC}/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${TURBADIR}/
+ @${CHMOD} -R o-rwx ${CONFDIR}/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/mail/horde4-turba/distinfo b/mail/horde4-turba/distinfo
index f5775c3913c3..5d6fd4dde5ca 100644
--- a/mail/horde4-turba/distinfo
+++ b/mail/horde4-turba/distinfo
@@ -1,3 +1,3 @@
-MD5 (turba-h3-2.1.3.tar.gz) = a0407717f3f64fb33f6a57e2244a12b4
-SHA256 (turba-h3-2.1.3.tar.gz) = d12032c43e488fd5a4fe4e3bf30e95394136db04cedde9a865a4fb806b8c6367
-SIZE (turba-h3-2.1.3.tar.gz) = 1790717
+MD5 (turba-h3-2.1.4.tar.gz) = 950b5645ee75ed0df7a0f594c5e7d285
+SHA256 (turba-h3-2.1.4.tar.gz) = 46d31dd0f5e0e55ad78f82de1b001e4d8ba82a3294bd4205012e0680a62dda8a
+SIZE (turba-h3-2.1.4.tar.gz) = 1809857
diff --git a/mail/horde4-turba/pkg-plist b/mail/horde4-turba/pkg-plist
index c1129e5cc26d..325d862232a5 100644
--- a/mail/horde4-turba/pkg-plist
+++ b/mail/horde4-turba/pkg-plist
@@ -1,11 +1,3 @@
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LDAP
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%TURBADIR%%/add.php
%%TURBADIR%%/addressbooks.php
%%TURBADIR%%/browse.php
@@ -38,6 +30,7 @@
%%TURBADIR%%/lib/Object/Group.php
%%TURBADIR%%/lib/ObjectView.php
%%TURBADIR%%/lib/Renderer.php
+%%TURBADIR%%/lib/tests/tovcard.phpt
%%TURBADIR%%/lib/Turba.php
%%TURBADIR%%/lib/api.php
%%TURBADIR%%/lib/base.php
@@ -47,6 +40,7 @@
%%TURBADIR%%/locale/ar_SY/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/bg_BG/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/ca_ES/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/ca_ES/help.xml
%%TURBADIR%%/locale/cs_CZ/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/da_DK/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/de_DE/LC_MESSAGES/turba.mo
@@ -61,6 +55,7 @@
%%TURBADIR%%/locale/fi_FI/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/fi_FI/help.xml
%%TURBADIR%%/locale/fr_FR/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/fr_FR/help.xml
%%TURBADIR%%/locale/gl_ES/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/hu_HU/LC_MESSAGES/turba.mo
%%TURBADIR%%/locale/is_IS/LC_MESSAGES/turba.mo
@@ -183,7 +178,6 @@
%%TURBADIR%%/vcard.php
%%TURBADIR%%/view.php
%%HORDE_INC%%/httpd-turba.conf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%TURBADIR%%/themes/ideas
@dirrm %%TURBADIR%%/themes/graphics/menu
@dirrm %%TURBADIR%%/themes/graphics
@@ -272,6 +266,7 @@
@dirrm %%TURBADIR%%/locale/ar_SY/LC_MESSAGES
@dirrm %%TURBADIR%%/locale/ar_SY
@dirrm %%TURBADIR%%/locale
+@dirrm %%TURBADIR%%/lib/tests
@dirrm %%TURBADIR%%/lib/Object
@dirrm %%TURBADIR%%/lib/Driver
@dirrm %%TURBADIR%%/lib/Block