aboutsummaryrefslogtreecommitdiff
path: root/mail/hotwayd/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-21 09:26:12 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-21 09:26:12 +0000
commit08d02ac3ecb9a8fdfb7f0fb1cf67da8a652d5d3f (patch)
treeca545e04ce3d2f4d92a911bd873f452a16388de2 /mail/hotwayd/Makefile
parent5026e5d59e0110adb41ec0b38812db53dac8eb71 (diff)
downloadports-08d02ac3ecb9a8fdfb7f0fb1cf67da8a652d5d3f.tar.gz
ports-08d02ac3ecb9a8fdfb7f0fb1cf67da8a652d5d3f.zip
Notes
Diffstat (limited to 'mail/hotwayd/Makefile')
-rw-r--r--mail/hotwayd/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/mail/hotwayd/Makefile b/mail/hotwayd/Makefile
index c92b991c2ad5..b758eec5b7aa 100644
--- a/mail/hotwayd/Makefile
+++ b/mail/hotwayd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hotwayd
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.8
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hotwayd
@@ -16,16 +15,32 @@ MAINTAINER= john@jnielsen.net
COMMENT= A Hotmail -> POP3 gateway
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- iconv.3:${PORTSDIR}/converters/libiconv
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ sasl2.2:${PORTSDIR}/security/cyrus-sasl2
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-MAN1= hotwayd.1
-PLIST_FILES= sbin/hotwayd
+MAN1= hotwayd.1 \
+ hotsmtpd.1
-post-install:
+DOC_FILES= AUTHORS COPYING INSTALL NEWS README README.hotsmtpd VERSION
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+
+post-install: install-doc-files display-message
+
+install-doc-files:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+display-message:
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>