aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-04-04 21:45:52 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-04-04 21:45:52 +0000
commitb0d35cb232a3e4fbed3627068b6a2576555eacff (patch)
treeba40f8fe3bf1c0e787efd360b7e769334f367ce8 /mail/imap-uw
parent650550f57bd3ef514b8f8a3769df26fd08b262aa (diff)
downloadports-b0d35cb232a3e4fbed3627068b6a2576555eacff.tar.gz
ports-b0d35cb232a3e4fbed3627068b6a2576555eacff.zip
Notes
Diffstat (limited to 'mail/imap-uw')
-rw-r--r--mail/imap-uw/Makefile38
-rw-r--r--mail/imap-uw/distinfo2
-rw-r--r--mail/imap-uw/pkg-message9
3 files changed, 38 insertions, 11 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 8135a1dc42eb..d18e3e59ce66 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imap
-PORTVERSION= 2000c
+PORTVERSION= 0104031813
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/%SUBDIR%/ \
@@ -14,8 +14,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.uni-halle.de/pub/mail/pine/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
PKGNAMESUFFIX= -uw
-DISTFILES= ${DISTNAME}.tar.Z \
- imap-utils.tar.Z
+DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.Z imap-utils.tar.Z
MAINTAINER= petef@databits.net
@@ -23,9 +23,16 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if defined(WITH_DRAC)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+.endif
MAN8= ipopd.8 imapd.8
+.if defined(WITH_SSL)
+ALL_TARGET= bsf SSLTYPE=unix
+.else
ALL_TARGET= bsf
+.endif
.include <bsd.port.pre.mk>
@@ -49,8 +56,9 @@ do-install:
${INSTALL_MAN} \
${WRKSRC}/src/ipopd/ipopd.8c ${PREFIX}/man/man8/ipopd.8
-.if defined(WITH_DRAC)
post-install:
+ @${CAT} ${PKGMESSAGE}
+.if defined(WITH_DRAC)
@${ECHO} "================================================================================"
@${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
@${ECHO} "the hostname of the DRAC server:"
@@ -58,8 +66,26 @@ post-install:
@${ECHO} "localhost"
@${ECHO} "================================================================================"
.endif
+.if defined(WITH_SSL)
+ @${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
+ @${ECHO} "cert\"."
+ @${ECHO}
+ @${ECHO} "Example inetd config for the SSL services:"
+ @${ECHO}
+ @${ECHO} "pop3s stream tcp nowait root /usr/local/libexec/ipop3d ipop3d"
+ @${ECHO} "imaps stream tcp nowait root /usr/local/libexec/imapd imapd"
+ @${ECHO}
+ @${ECHO} "Remember to recompile and reinstall your cclient port with SSL support too, if"
+ @${ECHO} "you had it installed without SSL support."
+ @${ECHO}
+ @${ECHO} "================================================================================"
+.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
+cert:
+ @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
+ @openssl req -new -x509 -days 365 -nodes -config ${FILESDIR}/imap-uw.cnf -out ${PREFIX}/certs/imapd.pem -keyout ${PREFIX}/certs/imapd.pem
+ @openssl x509 -subject -dates -fingerprint -noout -in ${PREFIX}/certs/imapd.pem
+ @${CHMOD} 700 ${PREFIX}/certs/imapd.pem
+ @${LN} -s ${PREFIX}/certs/imapd.pem ${PREFIX}/certs/ipop3d.pem
.include <bsd.port.post.mk>
diff --git a/mail/imap-uw/distinfo b/mail/imap-uw/distinfo
index 3437048116be..e60e98d340ba 100644
--- a/mail/imap-uw/distinfo
+++ b/mail/imap-uw/distinfo
@@ -1,2 +1,2 @@
-MD5 (imap-2000c.tar.Z) = 90bdc0670812234a0589286798575980
+MD5 (imap-2001.BETA.SNAP-0104031813.tar.Z) = 327a8494019c07880072a855eb24060f
MD5 (imap-utils.tar.Z) = a6453029f201b32e9ed761e662c47b0f
diff --git a/mail/imap-uw/pkg-message b/mail/imap-uw/pkg-message
index a2687d0f55da..ab37cbb21a5a 100644
--- a/mail/imap-uw/pkg-message
+++ b/mail/imap-uw/pkg-message
@@ -5,10 +5,11 @@ pop2 stream tcp nowait root /usr/local/libexec/ipop2d ipop2d
pop3 stream tcp nowait root /usr/local/libexec/ipop3d ipop3d
imap4 stream tcp nowait root /usr/local/libexec/imapd imapd
-If PAM authentication support has been compiled in you may need to add the
-following lines to /etc/pam.conf:
+If PAM authentication support has been compiled in you may need to add
+something like the following lines to /etc/pam.conf (PAM authentication is
+default):
imap auth required pam_unix.so try_first_pass
imap account required pam_unix.so try_first_pass
-pop auth required pam_unix.so try_first_pass
-pop account required pam_unix.so try_first_pass
+pop3 auth required pam_unix.so try_first_pass
+pop3 account required pam_unix.so try_first_pass