aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-25 02:29:04 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-25 02:29:04 +0000
commit6f6f635f01d1d59202f52ca8f509a93e2112fc73 (patch)
tree340e4abdf13b43649ca2247f464ffee7228e2bed /mail/imap-uw
parentffdaa2330b2144a866c73b6bc02ad3358e606f56 (diff)
downloadports-6f6f635f01d1d59202f52ca8f509a93e2112fc73.tar.gz
ports-6f6f635f01d1d59202f52ca8f509a93e2112fc73.zip
Notes
Diffstat (limited to 'mail/imap-uw')
-rw-r--r--mail/imap-uw/Makefile37
-rw-r--r--mail/imap-uw/distinfo8
-rw-r--r--mail/imap-uw/files/patch-ab38
-rw-r--r--mail/imap-uw/files/patch-ad19
-rw-r--r--mail/imap-uw/files/patch-ae47
-rw-r--r--mail/imap-uw/pkg-descr13
-rw-r--r--mail/imap-uw/pkg-plist1
7 files changed, 139 insertions, 24 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 4509deda9cd7..f0f50e9a5a3d 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -1,28 +1,37 @@
# New ports collection makefile for: imap-uw
-# Version required: 4.5
+# Version required: 4.7
# Date created: 9 Jan 1997
# Whom: pst
#
# $FreeBSD$
#
-DISTNAME= imap-4.5
-PKGNAME= imap-uw-4.5
+DISTNAME= imap-4.7
+PKGNAME= imap-uw-4.7
CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cac.washington.edu/imap/old/ \
- ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/old/ \
+MASTER_SITES= ftp://ftp.cac.washington.edu/imap/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/ \
+ http://mirror.nucba.ac.jp/mirror/imap/ \
ftp://ftp.uni-halle.de/pub/mail/pine/
EXTRACT_SUFX= .tar.Z
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ imap-utils${EXTRACT_SUFX} \
+ ${DISTNAME}.lock-patch.tar
MAINTAINER= imap-uw@freebsd.ady.ro
Y2K= http://www.washington.edu/imap/IMAP-FAQs/FAQ-00002.html
+PAMAUTH?= no
+.if ${PAMAUTH} != "no"
+ALL_TARGET= bfp
+.else
ALL_TARGET= bsf
+.endif
MAN8= ipopd.8 imapd.8
SHLIBBASE= c-client4
-SHLIBMAJ= 5
+SHLIBMAJ= 7
SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}
MAKE_ENV= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
PLIST_SUB= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
@@ -35,6 +44,17 @@ SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}.0
post-configure:
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"
+.if ${PAMAUTH} != "no"
+ @${ECHO_MSG} ">> Building with PAM support"
+.else
+ @${ECHO_MSG} ">> You can use PAM authentication building with \"PAMAUTH=yes\""
+.endif
+
+pre-patch:
+ @${CP} -f ${WRKDIR}/lock-patch/*.c ${WRKSRC}/src/osdep/unix/
+
+post-build:
+ @(cd ${WRKDIR}/mlock; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} all)
do-install:
${INSTALL_DATA} ${WRKSRC}/c-client/mail.h ${PREFIX}/include
@@ -48,6 +68,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/imapd/imapd ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/ipopd/ipop2d ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/ipopd/ipop3d ${PREFIX}/libexec
+ ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g mail -m 2711 \
+ ${WRKDIR}/mlock/mlock ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/mtest/mtest ${PREFIX}/bin/mboxtest
${INSTALL_MAN} \
${WRKSRC}/src/imapd/imapd.8c ${PREFIX}/man/man8/imapd.8
@@ -56,5 +78,8 @@ do-install:
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+.if ${PAMAUTH} != "no"
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.post.mk>
diff --git a/mail/imap-uw/distinfo b/mail/imap-uw/distinfo
index 60e3e3193c4a..7eaf38cef2ef 100644
--- a/mail/imap-uw/distinfo
+++ b/mail/imap-uw/distinfo
@@ -1,2 +1,6 @@
-MD5 (imap-4.5.tar.Z) = 24e5ff01e0f14ecc647f10a9148a9dbd
-SIZE (imap-4.5.tar.Z) = 1656569
+MD5 (imap-4.7.tar.Z) = 73fe0bb4878874945b5a692dd7205b58
+SIZE (imap-4.7.tar.Z) = 1862753
+MD5 (imap-4.7.lock-patch.tar) = c25277ed63fa832bb0b066e8b49deebb
+SIZE (imap-4.7.lock-patch.tar) = 180224
+MD5 (imap-utils.tar.Z) = 5fd2828029a0f91e5760ec1ab64377fc
+SIZE (imap-utils.tar.Z) = 72287
diff --git a/mail/imap-uw/files/patch-ab b/mail/imap-uw/files/patch-ab
index d39f32a7aa59..4b04174ab4d7 100644
--- a/mail/imap-uw/files/patch-ab
+++ b/mail/imap-uw/files/patch-ab
@@ -1,6 +1,6 @@
---- src/osdep/unix/Makefile.orig Wed Jan 27 01:17:39 1999
-+++ src/osdep/unix/Makefile Sat Feb 27 17:16:00 1999
-@@ -100,7 +100,7 @@
+--- src/osdep/unix/Makefile.orig Wed Nov 17 04:05:48 1999
++++ src/osdep/unix/Makefile Wed Dec 22 00:43:23 1999
+@@ -104,7 +104,7 @@
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
@@ -9,8 +9,8 @@
MAKE=make
MV=mv
RM=rm -rf
-@@ -115,6 +115,10 @@
- PASSWDTYPE=$(PASSWDTYPE)
+@@ -119,6 +119,10 @@
+ PASSWDTYPE=$(PASSWDTYPE) SPECIALAUTHENTICATORS="$(SPECIALAUTHENTICATORS)"
BUILD=$(MAKE) build $(BUILDOPTIONS)
+# Need this for the shared library rule to work correctly
@@ -20,16 +20,34 @@
# Here if no make argument established
missing: osdep.h
-@@ -190,7 +194,7 @@
+@@ -178,6 +182,16 @@
+ BASECFLAGS="-g -B/usr/lib/big/ -Dvoid=char -Dconst= -DNFSKLUDGE" \
+ RANLIB=true ARRC="ar -rc"
+
++bfp: # FreeBSD Pluggable Authentication Modules
++ $(BUILD) `cat EXTRASPECIALS` OS=bsi SIGTYPE=psx \
++ CHECKPW=pam \
++ SPOOLDIR=/var \
++ ACTIVEFILE=/usr/local/news/lib/active \
++ RSHPATH=/usr/bin/rsh \
++ LOCKPGM=$(PREFIX)/libexec/mlock \
++ BASECFLAGS="-DNFSKLUDGE" \
++ BASELDFLAGS="-lpam -lcrypt"
++
+ bs3: # BSD/i386 3.0 or higher
+ $(BUILD) `cat EXTRASPECIALS` OS=bsi CHECKPW=bsi LOGINPW=bsi \
+ SPOOLDIR=/var NEWSSPOOL=/var/news/spool \
+@@ -194,7 +208,8 @@
SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
RSHPATH=/usr/bin/rsh \
- BASECFLAGS="-g -O -pipe -DNFSKLUDGE" \
-+ BASECFLAGS="-DNFSKLUDGE -DIGNORE_LOCK_EACCES_ERRORS" \
++ LOCKPGM=$(PREFIX)/libexec/mlock \
++ BASECFLAGS="-DNFSKLUDGE" \
BASELDFLAGS="-lcrypt"
bsi: # BSD/i386
-@@ -606,19 +610,31 @@
+@@ -627,19 +642,31 @@
# Build it!
@@ -63,7 +81,7 @@
# Dependencies
-@@ -652,7 +668,7 @@
+@@ -673,7 +700,7 @@
# OS-dependent
@@ -72,7 +90,7 @@
osdep.h env_unix.h tcp_unix.h \
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c \
auths.c flock.c flockbsd.c flcksafe.c fsync.c gethstid.c \
-@@ -664,7 +680,12 @@
+@@ -685,7 +712,12 @@
write.c \
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
OSCFLAGS
diff --git a/mail/imap-uw/files/patch-ad b/mail/imap-uw/files/patch-ad
new file mode 100644
index 000000000000..464a98cd60ec
--- /dev/null
+++ b/mail/imap-uw/files/patch-ad
@@ -0,0 +1,19 @@
+--- Makefile.orig Mon Nov 15 22:20:34 1999
++++ Makefile Sun Dec 19 14:52:58 1999
+@@ -49,6 +49,7 @@
+ # art AIX 2.2.1 for RT
+ # asv Altos SVR4
+ # aux A/UX
++# bfp FreeBSD with Pluggable Authentication Modules (PAM)
+ # bs3 BSD/i386 3.0 and higher
+ # bsd generic BSD 4.3 (as in ancient 1980s version)
+ # bsf FreeBSD
+@@ -293,7 +294,7 @@
+
+ # Note on SCO you may have to set LN to "ln".
+
+-a32 a41 aix bs3 bsf bsi bso d-g d54 do4 drs epx gas gh9 ghp gs5 gso gsu gul hpp hpx lnp lyn mct mnt neb nxt nx3 osf os4 ptx qnx sc5 sco sgi sg6 shp sl4 sl5 slx snx sol sos uw2: an
++a32 a41 aix bfp bs3 bsf bsi bso d-g d54 do4 drs epx gas gh9 ghp gs5 gso gsu gul hpp hpx lnp lyn mct mnt neb nxt nx3 osf os4 ptx qnx sc5 sco sgi sg6 shp sl4 sl5 slx snx sol sos uw2: an
+ $(BUILD) OS=$@
+
+ # If you use sv4, you may find that it works to move it to use the an process.
diff --git a/mail/imap-uw/files/patch-ae b/mail/imap-uw/files/patch-ae
new file mode 100644
index 000000000000..a3b490909a09
--- /dev/null
+++ b/mail/imap-uw/files/patch-ae
@@ -0,0 +1,47 @@
+--- src/mtest/mtest.c.orig Sat May 29 08:07:06 1999
++++ src/mtest/mtest.c Sun Dec 19 15:29:29 1999
+@@ -95,6 +95,7 @@
+ void status (MAILSTREAM *stream);
+ void prompt (char *msg,char *txt);
+ void smtptest (long debug);
++char *safegets(char *buf);
+
+ /* Main program - initialization */
+
+@@ -528,7 +529,7 @@
+ void prompt (char *msg,char *txt)
+ {
+ printf ("%s",msg);
+- gets (txt);
++ safegets (txt);
+ }
+
+ /* Interfaces to C-client */
+@@ -713,7 +714,7 @@
+ puts (" Msg (end with a line with only a '.'):");
+ body->type = TYPETEXT;
+ *text = '\0';
+- while (gets (line)) {
++ while (safegets (line)) {
+ if (line[0] == '.') {
+ if (line[1] == '\0') break;
+ else strcat (text,".");
+@@ -744,4 +745,18 @@
+ else puts ("[Can't open connection to any server]");
+ mail_free_envelope (&msg);
+ mail_free_body (&body);
++}
++
++char *safegets(char *buf) {
++ char *p;
++
++ if (!fgets(buf, MAILTMPLEN, stdin)) {
++ return NULL;
++ }
++
++ if ((p = strchr(buf, '\n')) != NULL) {
++ *p = '\0';
++ }
++
++ return buf;
+ }
diff --git a/mail/imap-uw/pkg-descr b/mail/imap-uw/pkg-descr
index 8d3be9e81bf5..6f0b9e72e9e9 100644
--- a/mail/imap-uw/pkg-descr
+++ b/mail/imap-uw/pkg-descr
@@ -1,5 +1,5 @@
This is the IMAP4rev1 server from the University of Washington.
-Included are backwares-comaptible (almost) POP2 and POP3 servers.
+Included are (almost) backwards-compatible POP2 and POP3 servers.
ipop2d POP2 daemon
ipop3d POP3 daemon
@@ -12,9 +12,10 @@ pop2 stream tcp nowait root /usr/local/libexec/ipop2d ipop2d
pop3 stream tcp nowait root /usr/local/libexec/ipop3d ipop3d
imap4 stream tcp nowait root /usr/local/libexec/imapd imapd
-You may also have to edit your /etc/services (or Yellow Pages,
-NetInfo, etc. equivalent) to register these services, such as:
+If you compiled in PAM authentication support then you also have to add the
+following lines to your /etc/pam.conf:
-pop 109/tcp
-pop3 110/tcp
-imap4 143/tcp [imap2 and imap4 share the same port again]
+imap auth required pam_unix.so try_first_pass
+imap account required pam_unix.so try_first_pass
+pop auth required pam_unix.so try_first_pass
+pop account required pam_unix.so try_first_pass
diff --git a/mail/imap-uw/pkg-plist b/mail/imap-uw/pkg-plist
index 3f57af7f11f7..2b0b83f7d58d 100644
--- a/mail/imap-uw/pkg-plist
+++ b/mail/imap-uw/pkg-plist
@@ -10,3 +10,4 @@ lib/lib%%SHLIBBASE%%.so
libexec/imapd
libexec/ipop2d
libexec/ipop3d
+libexec/mlock