aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2007-07-01 20:57:04 +0000
committerAnders Nordby <anders@FreeBSD.org>2007-07-01 20:57:04 +0000
commita138d284c8fda23091a9ddd17f72b9304c8164de (patch)
tree357eb057f11bf13b740b9c5904b54a91e3d256f2 /mail/imap-uw
parent1dfb934a2381e8013f999cd0ab5b5a27bb13bbb3 (diff)
downloadports-a138d284c8fda23091a9ddd17f72b9304c8164de.tar.gz
ports-a138d284c8fda23091a9ddd17f72b9304c8164de.zip
Notes
Diffstat (limited to 'mail/imap-uw')
-rw-r--r--mail/imap-uw/Makefile6
-rw-r--r--mail/imap-uw/files/patch-ab28
2 files changed, 16 insertions, 18 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index b8f127703b4d..e4fe992caae0 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -31,6 +31,8 @@ OPTIONS= SSL "Compile with SSL support" on \
NETSCAPE_BRAIN_DAMAGE "See Makefile for documentation" off \
ENTOURAGE_BRAIN_DAMAGE "See Makefile for documentation" off
+.include <bsd.port.pre.mk>
+
LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if defined(WITH_DRAC)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
@@ -44,7 +46,7 @@ MAN8= ipopd.8 imapd.8
ALL_TARGET= bsf
.if defined(WITHOUT_SSL)
-MAKE_ARGS+= SSLTYPE=none
+MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
USE_OPENSSL= yes
.if defined(WITH_SSL_AND_PLAINTEXT)
@@ -64,8 +66,6 @@ MAKE_ARGS+= WITH_ENTOURAGE_BRAIN_DAMAGE=yes
.endif
# See src/imapd/Makefile for more information about these three options.
-.include <bsd.port.pre.mk>
-
pre-build:
@${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
.if !defined(WITHOUT_SSL)
diff --git a/mail/imap-uw/files/patch-ab b/mail/imap-uw/files/patch-ab
index 6de8fc321668..a79003f09f3d 100644
--- a/mail/imap-uw/files/patch-ab
+++ b/mail/imap-uw/files/patch-ab
@@ -1,25 +1,23 @@
---- src/osdep/unix/Makefile.orig Fri Apr 30 02:08:48 2004
-+++ src/osdep/unix/Makefile Fri Jun 4 07:34:19 2004
-@@ -29,13 +29,13 @@
+--- src/osdep/unix/Makefile.orig Sat Apr 30 22:51:13 2005
++++ src/osdep/unix/Makefile Sun Jul 1 22:36:01 2007
+@@ -41,13 +41,13 @@
# Extended flags needed for SSL. You may need to modify.
-SSLDIR=/usr/local/ssl
-SSLCERTS=$(SSLDIR)/certs
-+SSLDIR=$(OPENSSLBASE)
++#SSLDIR=/usr/local/ssl
+SSLCERTS=$(PREFIX)/certs
SSLKEYS=$(SSLCERTS)
--SSLINCLUDE=$(SSLDIR)/include
--SSLLIB=$(SSLDIR)/lib
-+SSLINCLUDE=$(OPENSSLINC)
-+SSLLIB=$(OPENSSLLIB)
+ SSLINCLUDE=$(SSLDIR)/include
+ SSLLIB=$(SSLDIR)/lib
-SSLCRYPTO=-lcrypto
+SSLCRYPTO=-lcrypto -lcrypt
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
# to use this instead
-@@ -48,7 +48,7 @@
+@@ -60,7 +60,7 @@
SSLCFLAGS= -I$(SSLINCLUDE) -I$(SSLINCLUDE)/openssl\
-DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\" -DSSL_KEY_DIRECTORY=\"$(SSLKEYS)\"
@@ -28,7 +26,7 @@
# Extended flags needed for non-standard passwd types. You may need to modify.
-@@ -62,7 +62,7 @@
+@@ -74,7 +74,7 @@
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
DCELDFLAGS= -ldce
@@ -37,7 +35,7 @@
# Build parameters normally set by the individual port
-@@ -99,7 +99,7 @@
+@@ -111,7 +111,7 @@
# Commands possibly overriden by the individual port
ARRC=ar rc
@@ -46,7 +44,7 @@
LN=ln -s
RANLIB=ranlib
-@@ -117,7 +117,7 @@
+@@ -129,7 +129,7 @@
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
@@ -55,7 +53,7 @@
CAT=cat
MAKE=make
-@@ -200,6 +200,15 @@
+@@ -212,6 +212,15 @@
BASECFLAGS="-g -B/usr/lib/big/ -Dvoid=char -Dconst=" \
RANLIB=true ARRC="ar -rc"
@@ -71,7 +69,7 @@
bs3: # BSD/i386 3.0 or higher
$(BUILD) `$(CAT) SPECIALS` OS=bsi \
CHECKPW=bsi LOGINPW=bsi CRXTYPE=nfs \
-@@ -219,8 +228,9 @@
+@@ -231,8 +240,9 @@
SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
RSHPATH=/usr/bin/rsh \
@@ -83,7 +81,7 @@
bsi: # BSD/i386
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
-@@ -788,7 +798,7 @@
+@@ -803,7 +813,7 @@
build: clean once $(ARCHIVE)