aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-02-15 01:12:37 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-02-15 01:12:37 +0000
commit7cb7f42027151f49d25d9ea46f5761c94dd0b51d (patch)
treec91b68dde611bea7a5ebd04a8a2f8a414ba294dd /mail/imap-uw
parent3035c026fc19c6352ef1f9ef72282b63ef39a4ee (diff)
downloadports-7cb7f42027151f49d25d9ea46f5761c94dd0b51d.tar.gz
ports-7cb7f42027151f49d25d9ea46f5761c94dd0b51d.zip
Notes
Diffstat (limited to 'mail/imap-uw')
-rw-r--r--mail/imap-uw/files/patch-ac18
-rw-r--r--mail/imap-uw/files/patch-ae35
2 files changed, 30 insertions, 23 deletions
diff --git a/mail/imap-uw/files/patch-ac b/mail/imap-uw/files/patch-ac
index 566d1b961bd9..9d324e6b5e40 100644
--- a/mail/imap-uw/files/patch-ac
+++ b/mail/imap-uw/files/patch-ac
@@ -32,9 +32,9 @@
ipopd: ipop2d ipop3d
---- src/mtest/Makefile.orig Wed Apr 15 07:42:04 1998
-+++ src/mtest/Makefile Fri Feb 4 14:37:44 2000
-@@ -39,14 +39,16 @@
+--- src/mtest/Makefile.orig Wed Apr 15 01:42:04 1998
++++ src/mtest/Makefile Sat Oct 10 21:48:18 1998
+@@ -39,7 +39,7 @@
CC = `cat $C/CCTYPE`
CFLAGS = -I$C `cat $C/CFLAGS`
@@ -43,15 +43,3 @@
all: mtest
--mtest: $(CCLIENTLIB) mtest.o
-- $(CC) $(CFLAGS) -o mtest mtest.o $(LDFLAGS)
-+mtest: $(CCLIENTLIB) mtest.o safegets.o
-+ $(CC) $(CFLAGS) -o mtest mtest.o safegets.o $(LDFLAGS)
-
--mtest.o: $C/mail.h $C/misc.h $C/osdep.h $C/rfc822.h $C/smtp.h $C/nntp.h
-+mtest.o: safegets.h $C/mail.h $C/misc.h $C/osdep.h $C/rfc822.h $C/smtp.h $C/nntp.h
-+
-+safegets.o: safegets.h $C/mail.h
-
- $(CCLIENTLIB):
- cd $C;make
diff --git a/mail/imap-uw/files/patch-ae b/mail/imap-uw/files/patch-ae
index 7ede8619fd27..a3b490909a09 100644
--- a/mail/imap-uw/files/patch-ae
+++ b/mail/imap-uw/files/patch-ae
@@ -1,12 +1,12 @@
--- src/mtest/mtest.c.orig Sat May 29 08:07:06 1999
-+++ src/mtest/mtest.c Fri Feb 4 12:25:32 2000
-@@ -49,6 +49,7 @@
- #include "rfc822.h"
- #include "smtp.h"
- #include "nntp.h"
-+#include "safegets.h"
-
- /* Excellent reasons to hate ifdefs, and why my real code never uses them */
++++ src/mtest/mtest.c Sun Dec 19 15:29:29 1999
+@@ -95,6 +95,7 @@
+ void status (MAILSTREAM *stream);
+ void prompt (char *msg,char *txt);
+ void smtptest (long debug);
++char *safegets(char *buf);
+
+ /* Main program - initialization */
@@ -528,7 +529,7 @@
void prompt (char *msg,char *txt)
@@ -26,3 +26,22 @@
if (line[0] == '.') {
if (line[1] == '\0') break;
else strcat (text,".");
+@@ -744,4 +745,18 @@
+ else puts ("[Can't open connection to any server]");
+ mail_free_envelope (&msg);
+ mail_free_body (&body);
++}
++
++char *safegets(char *buf) {
++ char *p;
++
++ if (!fgets(buf, MAILTMPLEN, stdin)) {
++ return NULL;
++ }
++
++ if ((p = strchr(buf, '\n')) != NULL) {
++ *p = '\0';
++ }
++
++ return buf;
+ }