aboutsummaryrefslogtreecommitdiff
path: root/mail/imp3/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-05-16 08:22:16 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-05-16 08:22:16 +0000
commit38a338d421ac7332b4e3ac7f389052fcf3fe19a5 (patch)
tree19ddcbc5997f4b90cb79e5cd7e4032ba070bb8a6 /mail/imp3/Makefile
parent87808b3a836795fd641f6336ef35adf8a76bd461 (diff)
Upgrade to 3.1 RC2.
PR: ports/36906 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59238
Diffstat (limited to 'mail/imp3/Makefile')
-rw-r--r--mail/imp3/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index d4df326559fa..8c3f93ccdf35 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= imp
-PORTVERSION= 3.0
-PORTREVISION= 2
+PORTVERSION= 3.1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/imp/tarballs/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-RC2
MAINTAINER= thierry@pompo.net
@@ -118,12 +118,13 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/aspell:${PORTSDIR}/textproc/aspell
.endif
.endif
-IS_INTERACTIVE= 'need to build mod_php4 with mcrypt option set.'
+IS_INTERACTIVE= 'need to build mod_php4 with mcrypt, cclient with SSL.'
NO_BUILD= yes
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL
CONFFILE= conf.php filter.txt header.txt html.php menu.php \
mime_drivers.php motd.php prefs.php servers.php \
trailer.txt
+SUB_DIRS= config graphics lib locale scripts templates po
LHORDEDIR?= www/horde
LIMPDIR?= ${LHORDEDIR}/imp
@@ -227,9 +228,9 @@ pre-install:
do-install:
@${MKDIR} ${IMPDIR}
- @${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${IMPDIR}
- @${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${IMPDIR}
- @${CP} -Rp ${WRKSRC}/po ${IMPDIR}
+.for REP in ${SUB_DIRS}
+ @${CP} -Rp ${WRKSRC}/${REP} ${IMPDIR}
+.endfor
@${CP} -p ${WRKSRC}/*.php ${IMPDIR}
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \