aboutsummaryrefslogtreecommitdiff
path: root/mail/jboss-mailservices/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-01-11 10:08:04 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-01-11 10:08:04 +0000
commit39eaab10f0e9176ee251aeb6cf8534d1d667a004 (patch)
treebce976db7150e4c221e31dee5fcd2cc456a4f0f9 /mail/jboss-mailservices/Makefile
parent5a2ba729e51e20d0bf765ffa33005143733f6d6d (diff)
downloadports-39eaab10f0e9176ee251aeb6cf8534d1d667a004.tar.gz
ports-39eaab10f0e9176ee251aeb6cf8534d1d667a004.zip
Notes
Diffstat (limited to 'mail/jboss-mailservices/Makefile')
-rw-r--r--mail/jboss-mailservices/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/jboss-mailservices/Makefile b/mail/jboss-mailservices/Makefile
new file mode 100644
index 000000000000..c4511233a04b
--- /dev/null
+++ b/mail/jboss-mailservices/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: JBoss Mail Services
+# Date created: Thu Jan 6 13:39:18 EET 2005
+# Whom: Anton Yudin <toha@toha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jboss-mailservices
+PORTVERSION= m1
+CATEGORIES= mail java
+MASTER_SITES= http://www.jboss.org/wiki/attach?page=MailServicesMilestoneReleases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-final
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= JBoss Mail Services
+
+RUN_DEPENDS= ${LOCALBASE}/jboss4.0/server/default/conf/jboss-service.xml:${PORTSDIR}/java/jboss4
+
+USE_JAVA= YES
+JAVA_VERSION= 1.4+
+NO_BUILD= YES
+USE_ZIP= YES
+
+DEPLOY_PATH= ${LOCALBASE}/jboss4.0/server/default/deploy
+WRKSRC= ${WRKDIR}/deploy
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ cd ${WRKSRC} && ${FIND} . -type d -exec ${INSTALL} -d ${DEPLOY_PATH}/'{}' \; && \
+ ${FIND} . -type f -exec ${INSTALL_DATA} '{}' ${DEPLOY_PATH}/'{}' \;
+
+post-install:
+ @${FIND} -s ${WRKSRC}/mail.ear -not -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},${DEPLOY_PATH:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/mail.ear -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},@dirrm ${DEPLOY_PATH:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>