aboutsummaryrefslogtreecommitdiff
path: root/mail/kavmilter/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-06-16 21:15:42 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-06-16 21:15:42 +0000
commiteffcda40f4e516e13e64704f9875dc868c214ba3 (patch)
tree3e8dd365f540f9017f5690cdf8e31ec668ce42f9 /mail/kavmilter/Makefile
parent3fcfb79518b7f2e5b3dbf9352df40326bf43f35e (diff)
Notes
Diffstat (limited to 'mail/kavmilter/Makefile')
-rw-r--r--mail/kavmilter/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/mail/kavmilter/Makefile b/mail/kavmilter/Makefile
new file mode 100644
index 000000000000..bdcbadc946a3
--- /dev/null
+++ b/mail/kavmilter/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: kavmilter
+# Date created: 12 Jun 2003
+# Whom: Rashid N. Achilov <shelton@granch.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kavmilter
+PORTVERSION= 0.91.3
+CATEGORIES= mail
+MASTER_SITES= ftp://granch.ru/pub/kavmilter/
+
+MAINTAINER= shelton@granch.ru
+COMMENT= Sendmail antivirus filter, based on Kaspersky Antivirus and Milter API
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+.if !exists(/usr/lib/libmilter.a)
+IGNORE= requires Sendmail 8.12; upgrade the base system
+.endif
+
+USE_BZIP2= yes
+USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
+
+MAN5= kavmilter.5
+MAN8= kavmilter.8
+
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${MAKEFILE}
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/libexec/kavmilter
+
+ ${INSTALL_SCRIPT} -m 751 ${WRKSRC}/kavmilter.sh.sample ${PREFIX}/etc/rc.d/kavmilter.sh.sample
+ ${INSTALL_SCRIPT} -m 644 ${WRKSRC}/kavmilter.conf ${PREFIX}/etc/kavmilter.conf.sample
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README CHANGES
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>