aboutsummaryrefslogtreecommitdiff
path: root/mail/kbiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2002-10-30 13:12:20 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2002-10-30 13:12:20 +0000
commit086cc202712e330e2abb5bfffedfc84d3bd78fc2 (patch)
treef80855c06b5e84f6afa05a77eb9fe19c24c1c078 /mail/kbiff
parent85441d7b1868c98f3b2423e86fec11f08b239aa8 (diff)
downloadports-086cc202712e330e2abb5bfffedfc84d3bd78fc2.tar.gz
ports-086cc202712e330e2abb5bfffedfc84d3bd78fc2.zip
Notes
Diffstat (limited to 'mail/kbiff')
-rw-r--r--mail/kbiff/Makefile6
-rw-r--r--mail/kbiff/files/patch-kbiff-setupdlg.cpp11
2 files changed, 15 insertions, 2 deletions
diff --git a/mail/kbiff/Makefile b/mail/kbiff/Makefile
index 8784b9790583..830f692ac4c7 100644
--- a/mail/kbiff/Makefile
+++ b/mail/kbiff/Makefile
@@ -7,10 +7,11 @@
PORTNAME= kbiff
PORTVERSION= 3.6.1
+PORTREVISION= 1
CATEGORIES= mail kde
MASTER_SITES= http://devel-home.kde.org/~granroth/kbiff/
-MAINTAINER= tilman@arved.de
+MAINTAINER= arved@FreeBSD.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
@@ -18,7 +19,8 @@ USE_KDELIBS_VER=3
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+ --disable-fast-perl
USE_REINPLACE= yes
post-patch:
diff --git a/mail/kbiff/files/patch-kbiff-setupdlg.cpp b/mail/kbiff/files/patch-kbiff-setupdlg.cpp
new file mode 100644
index 000000000000..12897f3c389d
--- /dev/null
+++ b/mail/kbiff/files/patch-kbiff-setupdlg.cpp
@@ -0,0 +1,11 @@
+--- kbiff/setupdlg.cpp.orig Tue Oct 15 20:13:12 2002
++++ kbiff/setupdlg.cpp Tue Oct 15 20:16:13 2002
+@@ -779,6 +779,8 @@
+ checkBeep = new QCheckBox(i18n("System &Beep"), this);
+ checkNotify = new QCheckBox(i18n("N&otify"), this);
+ checkStatus = new QCheckBox(i18n("&Floating Status"), this);
++ checkStatus->setChecked(false);
++ checkStatus->setEnabled(false);
+
+ // connect some slots and signals
+ connect(buttonBrowsePlaySound, SIGNAL(clicked()), SLOT(browsePlaySound()));