aboutsummaryrefslogtreecommitdiff
path: root/mail/kshowmail/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-04-14 10:06:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-04-14 10:06:41 +0000
commit5b1fd5d7514fe128090ca33499da4e0b2fd25b43 (patch)
treed5cfe3549b7a653c0bbd4ee361cb046fc836d206 /mail/kshowmail/Makefile
parentcd0678e85891fb5758deb6dde2fe05715bb0aa98 (diff)
downloadports-5b1fd5d7514fe128090ca33499da4e0b2fd25b43.tar.gz
ports-5b1fd5d7514fe128090ca33499da4e0b2fd25b43.zip
Notes
Diffstat (limited to 'mail/kshowmail/Makefile')
-rw-r--r--mail/kshowmail/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/mail/kshowmail/Makefile b/mail/kshowmail/Makefile
index 0da68c3aa17d..4f91e40b3be2 100644
--- a/mail/kshowmail/Makefile
+++ b/mail/kshowmail/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= kshowmail
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.9.1
CATEGORIES= mail kde
MASTER_SITES= SF
@@ -19,9 +19,23 @@ USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:261:env automake:19:env libtool:15:env
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB= NLS=""
+.endif
+
+post-patch:
+.if defined(WITHOUT_NLS)
+ ${REINPLACE_CMD} -e 's|po||g' ${WRKSRC}/Makefile.am
+.endif
+
pre-configure:
@cd ${WRKSRC}/admin && ${RM} -f ltmain.sh && ${CP} -f ${LTMAIN} .
@cd ${WRKSRC}/admin && ${RM} -f libtool.m4.in && ${CP} -f ${LIBTOOL_M4} libtool.m4.in
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} -f admin/Makefile.common
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>