aboutsummaryrefslogtreecommitdiff
path: root/mail/lbdb
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-02-23 23:40:47 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-02-23 23:40:47 +0000
commit791ae5e6f24e89b947031e4707734cc35e183533 (patch)
tree07bed39e359123b8468433a9b500ff5932acd3f7 /mail/lbdb
parent14ab07779d8123f5f8ae7275d6090c1eb1940f3f (diff)
downloadports-791ae5e6f24e89b947031e4707734cc35e183533.tar.gz
ports-791ae5e6f24e89b947031e4707734cc35e183533.zip
Notes
Diffstat (limited to 'mail/lbdb')
-rw-r--r--mail/lbdb/Makefile48
-rw-r--r--mail/lbdb/distinfo4
-rw-r--r--mail/lbdb/pkg-plist5
3 files changed, 45 insertions, 12 deletions
diff --git a/mail/lbdb/Makefile b/mail/lbdb/Makefile
index 3b6f29dc26b3..2239c7214ed0 100644
--- a/mail/lbdb/Makefile
+++ b/mail/lbdb/Makefile
@@ -6,20 +6,52 @@
#
PORTNAME= lbdb
-PORTVERSION= 0.28.2
+PORTVERSION= 0.29
CATEGORIES= mail
MASTER_SITES= http://www.spinnaker.de/debian/
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= obraun@FreeBSD.org
COMMENT= Set of tools for use with mutt's external mail address query feature
-BUILD_DEPENDS= abook:${PORTSDIR}/mail/abook \
- gpg:${PORTSDIR}/security/gnupg
-RUN_DEPENDS= abook:${PORTSDIR}/mail/abook \
- gpg:${PORTSDIR}/security/gnupg
+.include <bsd.port.pre.mk>
-BROKEN= "Does not fetch"
+.if exists (${LOCALBASE}/bin/gpg)
+WITH_GPG= yes
+.endif
+.if exists (${LOCALBASE}/bin/abook)
+WITH_ABOOK= yes
+.endif
+.if exists (${X11BASE}/bin/evolution)
+WITH_EVOLUTION= yes
+.endif
+
+.if defined(PACKAGE_BUILDING)
+WITH_GPG= yes
+WITH_ABOOK= yes
+.endif
+
+.if defined(WITH_GPG)
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+PLIST_SUB+= GPG=""
+.else
+PLIST_SUB+= GPG="@comment "
+.endif
+.if defined(WITH_ABOOK)
+BUILD_DEPENDS+= abook:${PORTSDIR}/mail/abook
+RUN_DEPENDS+= abook:${PORTSDIR}/mail/abook
+PLIST_SUB+= ABOOK=""
+.else
+PLIST_SUB+= ABOOK="@comment "
+.endif
+.if defined(WITH_EVOLUTION)
+BUILD_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
+RUN_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
+PLIST_SUB+= EVOLUTION=""
+.else
+PLIST_SUB+= EVOLUTION="@comment "
+.endif
WRKSRC= ${WRKDIR}/lbdb-${PORTVERSION}
GNU_CONFIGURE= YES
@@ -30,4 +62,4 @@ USE_PERL5= yes
MAN1= nodelist2lbdb.1 lbdbq.1 lbdb-fetchaddr.1 lbdb_dotlock.1 \
mutt_ldap_query.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/lbdb/distinfo b/mail/lbdb/distinfo
index 9571f5a8582a..4aa8e14cf365 100644
--- a/mail/lbdb/distinfo
+++ b/mail/lbdb/distinfo
@@ -1,2 +1,2 @@
-MD5 (lbdb_0.28.2.tar.gz) = 68664271a4fc7605eec28ecb627a4a06
-SIZE (lbdb_0.28.2.tar.gz) = 84900
+MD5 (lbdb_0.29.tar.gz) = 1b29222036f564f45d22ce86284c0611
+SIZE (lbdb_0.29.tar.gz) = 85590
diff --git a/mail/lbdb/pkg-plist b/mail/lbdb/pkg-plist
index 3ca2f43dcea4..64bbebc3eb96 100644
--- a/mail/lbdb/pkg-plist
+++ b/mail/lbdb/pkg-plist
@@ -8,12 +8,13 @@ libexec/fetchaddr
libexec/lbdb-munge
libexec/lbdb_bbdb_query.el
libexec/lbdb_lib
-libexec/m_abook
+%%ABOOK%%libexec/m_abook
libexec/m_bbdb
+%%EVOLUTION%%libexec/m_evolution
libexec/m_fido
libexec/m_finger
libexec/m_gnomecard
-libexec/m_gpg
+%%GPG%%libexec/m_gpg
libexec/m_inmail
libexec/m_ldap
libexec/m_muttalias