aboutsummaryrefslogtreecommitdiff
path: root/mail/lens
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-05-02 15:46:02 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-05-02 15:46:02 +0000
commitac776416f2bec3d8c7eb7d5f1c78cc8fa2b35790 (patch)
treebc39aa2fe3922d821c108efa772e9cb8538cc34d /mail/lens
parent44f2e010ae4450fd78a57933d432e59b04e47463 (diff)
downloadports-ac776416f2bec3d8c7eb7d5f1c78cc8fa2b35790.tar.gz
ports-ac776416f2bec3d8c7eb7d5f1c78cc8fa2b35790.zip
Notes
Diffstat (limited to 'mail/lens')
-rw-r--r--mail/lens/Makefile36
-rw-r--r--mail/lens/distinfo3
-rw-r--r--mail/lens/pkg-descr5
-rw-r--r--mail/lens/pkg-plist12
4 files changed, 56 insertions, 0 deletions
diff --git a/mail/lens/Makefile b/mail/lens/Makefile
new file mode 100644
index 000000000000..716fcfcdbebe
--- /dev/null
+++ b/mail/lens/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Lens
+# Date created: 2006-03-31
+# Whom: TAKATSU Tomonari <tota@rtfm.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lens
+PORTVERSION= 0.2
+CATEGORIES= mail ruby
+MASTER_SITES= http://pitecan.com/Lens/
+
+MAINTAINER= tota@rtfm.jp
+COMMENT= A mail filter written in Ruby
+
+NO_BUILD= yes
+USE_RUBY= yes
+
+LIB_FILES= lens.rb maildir.rb message.rb parsedate.rb classify.rb
+RUBY_SHEBANG_FILES= lens
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/lens ${PREFIX}/bin
+ @${MKDIR} ${RUBY_SITELIBDIR}/lens
+.for f in ${LIB_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_SITELIBDIR}/lens
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lensrc.sample ${EXAMPLESDIR}/dot.lensrc
+ ${INSTALL_DATA} ${WRKSRC}/commandmailrc.sample ${EXAMPLESDIR}/dot.commandmailrc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/lens/distinfo b/mail/lens/distinfo
new file mode 100644
index 000000000000..c44cb4ff5393
--- /dev/null
+++ b/mail/lens/distinfo
@@ -0,0 +1,3 @@
+MD5 (lens-0.2.tar.gz) = cf2b45f038d65233e91b78d56abb5ba8
+SHA256 (lens-0.2.tar.gz) = e3c559ade7246784d03e7139a0fad253e77cc25594fee54f896b182c86244d52
+SIZE (lens-0.2.tar.gz) = 7786
diff --git a/mail/lens/pkg-descr b/mail/lens/pkg-descr
new file mode 100644
index 000000000000..7bf508f14770
--- /dev/null
+++ b/mail/lens/pkg-descr
@@ -0,0 +1,5 @@
+Lens is a mail filter written in Ruby. Lens can filter an
+incoming mail when it is received and filter mails in a Maildir.
+
+Author: Toshiyuki Masui
+WWW: http://pitecan.com/Lens/
diff --git a/mail/lens/pkg-plist b/mail/lens/pkg-plist
new file mode 100644
index 000000000000..42ebe78ef1d1
--- /dev/null
+++ b/mail/lens/pkg-plist
@@ -0,0 +1,12 @@
+bin/lens
+%%RUBY_SITELIBDIR%%/lens/classify.rb
+%%RUBY_SITELIBDIR%%/lens/lens.rb
+%%RUBY_SITELIBDIR%%/lens/maildir.rb
+%%RUBY_SITELIBDIR%%/lens/message.rb
+%%RUBY_SITELIBDIR%%/lens/parsedate.rb
+@dirrm %%RUBY_SITELIBDIR%%/lens
+%%EXAMPLESDIR%%/dot.commandmailrc
+%%EXAMPLESDIR%%/dot.lensrc
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%