aboutsummaryrefslogtreecommitdiff
path: root/mail/libcmime
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-08-10 14:49:45 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-08-10 14:49:45 +0000
commite5e93837a0e5405d344fc88f36f8bbdc42455786 (patch)
tree2abb064ae5fe5e6d9417d1f7cda42ae41c4c82a6 /mail/libcmime
parentfd08497edcfcf51974810cd05ecf0bdae0f88e92 (diff)
downloadports-e5e93837a0e5405d344fc88f36f8bbdc42455786.tar.gz
ports-e5e93837a0e5405d344fc88f36f8bbdc42455786.zip
mail/libcmime: Lightweight C mime library
libcmime is a lightweight mime library, written in C. It attempts to be a general library for parsing and creating mime email messages and is designed to provide an easy to use and easy to integrate interface for developers. libcmime is a pretty fresh project so the library is still in beta state and there will be early and frequent releases. WWW: http://www.libcmime.org/ PR: ports/181158 Submitted by: Axel Steiner <ast treibsand.com>
Notes
Notes: svn path=/head/; revision=324537
Diffstat (limited to 'mail/libcmime')
-rw-r--r--mail/libcmime/Makefile42
-rw-r--r--mail/libcmime/distinfo2
-rw-r--r--mail/libcmime/pkg-descr7
-rw-r--r--mail/libcmime/pkg-plist16
4 files changed, 67 insertions, 0 deletions
diff --git a/mail/libcmime/Makefile b/mail/libcmime/Makefile
new file mode 100644
index 000000000000..870f9a529d11
--- /dev/null
+++ b/mail/libcmime/Makefile
@@ -0,0 +1,42 @@
+# Created by: Axel Steiner <ast@treibsand.com>
+# $FreeBSD$
+
+PORTNAME= libcmime
+PORTVERSION= 0.1.7
+CATEGORIES= mail
+MASTER_SITES= http://www.libcmime.org/files/
+
+MAINTAINER= ast@treibsand.com
+COMMENT= Lightweight C mime library
+
+LICENSE= LGPL3
+
+BUILD_DEPENDS= bison>=1.8:${PORTSDIR}/devel/bison \
+ flex>=2.5.33:${PORTSDIR}/textproc/flex
+
+USES= cmake pkgconfig
+CMAKE_ARGS+= --no-warn-unused-cli -DCMAKE_PREFIX_PATH:PATH=${LOCALBASE}
+
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DEBUG DOCS
+
+PORTDOCS= AUTHORS CHANGELOG INSTALL README
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|\$${LIBDIR}(/pkgconfig)|$${CMAKE_INSTALL_PREFIX}/libdata\1|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/mail/libcmime/distinfo b/mail/libcmime/distinfo
new file mode 100644
index 000000000000..0578b6660293
--- /dev/null
+++ b/mail/libcmime/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcmime-0.1.7.tar.gz) = acaa0b8f3fed22ab2052723501c0c449e177105c224f0ccdfd699b65480bf858
+SIZE (libcmime-0.1.7.tar.gz) = 140786
diff --git a/mail/libcmime/pkg-descr b/mail/libcmime/pkg-descr
new file mode 100644
index 000000000000..70390ba42382
--- /dev/null
+++ b/mail/libcmime/pkg-descr
@@ -0,0 +1,7 @@
+libcmime is a lightweight mime library, written in C. It attempts to
+be a general library for parsing and creating mime email messages and
+is designed to provide an easy to use and easy to integrate interface
+for developers. libcmime is a pretty fresh project so the library is
+still in beta state and there will be early and frequent releases.
+
+WWW: http://www.libcmime.org/
diff --git a/mail/libcmime/pkg-plist b/mail/libcmime/pkg-plist
new file mode 100644
index 000000000000..02c5ac350be1
--- /dev/null
+++ b/mail/libcmime/pkg-plist
@@ -0,0 +1,16 @@
+include/cmime.h
+include/cmime/cmime_address.h
+include/cmime/cmime_base64.h
+include/cmime/cmime_config.h
+include/cmime/cmime_header.h
+include/cmime/cmime_list.h
+include/cmime/cmime_message.h
+include/cmime/cmime_part.h
+include/cmime/cmime_qp.h
+include/cmime/cmime_string.h
+include/cmime/cmime_util.h
+lib/libcmime.so
+lib/libcmime.so.0.1
+lib/libcmime.so.0.1.7
+libdata/pkgconfig/libcmime.pc
+@dirrm include/cmime