aboutsummaryrefslogtreecommitdiff
path: root/mail/libdomainkeys/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-05-23 09:51:05 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-05-23 09:51:05 +0000
commit4c217f887f35d6fd717d33526fa2faf0ebb3e97a (patch)
tree2b9038e2b8d9ad98719c1d9993960d33668f8fd8 /mail/libdomainkeys/Makefile
parent95e80732c420944cc2fe42f972daf43ebb4f30e6 (diff)
downloadports-4c217f887f35d6fd717d33526fa2faf0ebb3e97a.tar.gz
ports-4c217f887f35d6fd717d33526fa2faf0ebb3e97a.zip
Notes
Diffstat (limited to 'mail/libdomainkeys/Makefile')
-rw-r--r--mail/libdomainkeys/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/libdomainkeys/Makefile b/mail/libdomainkeys/Makefile
new file mode 100644
index 000000000000..edae4f6e8c42
--- /dev/null
+++ b/mail/libdomainkeys/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libdomainkeys
+# Date created: 16 May 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdomainkeys
+PORTVERSION= 0.63
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= domainkeys
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= DomainKeys library
+
+MAKE_ENV= PREFIX=${PREFIX} OPENSSLBASE="${OPENSSLBASE}"
+INSTALLS_SHLIB= YES
+SHLIB_MAJOR= 1
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+USE_OPENSSL= YES
+
+.if defined(NOPROFILE)
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
+ @${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
+ ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>