aboutsummaryrefslogtreecommitdiff
path: root/mail/libdomainkeys/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 12:25:41 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 12:25:41 +0000
commitc81f564a8ab1b472f8390ae8aa07732fe1980661 (patch)
treef45bdfb6f43eb830cf6e92a172fc6da85cb96b62 /mail/libdomainkeys/Makefile
parent9ce0247c70c2cf0d113a45093ace0b5066dba1d6 (diff)
downloadports-c81f564a8ab1b472f8390ae8aa07732fe1980661.tar.gz
ports-c81f564a8ab1b472f8390ae8aa07732fe1980661.zip
Notes
Diffstat (limited to 'mail/libdomainkeys/Makefile')
-rw-r--r--mail/libdomainkeys/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/mail/libdomainkeys/Makefile b/mail/libdomainkeys/Makefile
index 7a81ec9349be..945939100cf6 100644
--- a/mail/libdomainkeys/Makefile
+++ b/mail/libdomainkeys/Makefile
@@ -1,4 +1,4 @@
-# Created by: Sergey Skvortsov <skv@protey.ru>
+ Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
PORTNAME= libdomainkeys
@@ -9,21 +9,20 @@ MASTER_SITES= SF/domainkeys/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= DomainKeys library
-USE_LDCONFIG= YES
+USE_LDCONFIG= yes
SHLIB_MAJOR= 3
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
-USE_OPENSSL= YES
+USE_OPENSSL= yes
-NO_STAGE= yes
post-patch:
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
@${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
${FILESDIR}/Makefile > ${WRKSRC}/Makefile
post-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/dknewkey ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/test ${DATADIR}/dktest
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/dknewkey ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/test ${STAGEDIR}${DATADIR}/dktest
.include <bsd.port.mk>