aboutsummaryrefslogtreecommitdiff
path: root/mail/libesmtp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-05 13:45:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-05 13:45:39 +0000
commitc57133fc365bbbda0130bdef7e2be2f6212c7b74 (patch)
tree9fd8f3d259351b0293c2c2251beccb8764555320 /mail/libesmtp
parent58fb45f3dd6072a62c8853d31c25cee7e8140684 (diff)
downloadports-c57133fc365bbbda0130bdef7e2be2f6212c7b74.tar.gz
ports-c57133fc365bbbda0130bdef7e2be2f6212c7b74.zip
Notes
Diffstat (limited to 'mail/libesmtp')
-rw-r--r--mail/libesmtp/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 316546013339..fa852d4c3679 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= OPENSSL DEBUG DOCS EXAMPLES
OPTIONS_DEFAULT= OPENSSL
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -29,7 +29,6 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
@@ -45,15 +44,11 @@ CONFIGURE_ARGS+= --enable-debug
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS ChangeLog NEWS Notes README TODO
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>