aboutsummaryrefslogtreecommitdiff
path: root/mail/libesmtp
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2002-02-13 04:44:23 +0000
committerAde Lovett <ade@FreeBSD.org>2002-02-13 04:44:23 +0000
commite8ff45fadbbd59d8bb07ac7d78d11b3df812289d (patch)
treed10b337477595998f833ee5614f83d60563b1f4f /mail/libesmtp
parent2641883c3898e010de109ffd5539d125ffc373d7 (diff)
downloadports-e8ff45fadbbd59d8bb07ac7d78d11b3df812289d.tar.gz
ports-e8ff45fadbbd59d8bb07ac7d78d11b3df812289d.zip
Notes
Diffstat (limited to 'mail/libesmtp')
-rw-r--r--mail/libesmtp/Makefile10
-rw-r--r--mail/libesmtp/distinfo2
-rw-r--r--mail/libesmtp/files/patch-config.h.in10
-rw-r--r--mail/libesmtp/files/patch-ltmain.sh28
-rw-r--r--mail/libesmtp/files/patch-ntlm::ntlmstruct.c14
-rw-r--r--mail/libesmtp/pkg-plist2
6 files changed, 53 insertions, 13 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index d27c39d60329..994fd818a842 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libesmtp
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10p1
CATEGORIES= mail
MASTER_SITES= http://www.stafford.uklinux.net/libesmtp/ \
http://www.tobez.org/download/port-mirrors/mail/libesmtp/ \
@@ -16,7 +16,7 @@ MAINTAINER= jmcoopr@webmail.bmi.net
USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -26,6 +26,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
# require-all-recipients (implied by enable-all) is required for Balsa-1.3.x
CONFIGURE_ARGS= --enable-all
+pre-configure:
+ @${CP} ${LOCALBASE}/share/libtool/ltconfig ${WRKSRC}
+
+post-configure:
+ @cd ${WRKSRC} && ./ltconfig ./ltmain.sh
+
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
diff --git a/mail/libesmtp/distinfo b/mail/libesmtp/distinfo
index c5ed8f9032e6..5f548a1e4451 100644
--- a/mail/libesmtp/distinfo
+++ b/mail/libesmtp/distinfo
@@ -1 +1 @@
-MD5 (libesmtp-0.8.9.tar.bz2) = 546e765b3809f2704e50a9cc03301657
+MD5 (libesmtp-0.8.10p1.tar.bz2) = d3958b7cc564df094d204fcced2f74cd
diff --git a/mail/libesmtp/files/patch-config.h.in b/mail/libesmtp/files/patch-config.h.in
deleted file mode 100644
index eec95e099ded..000000000000
--- a/mail/libesmtp/files/patch-config.h.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- config.h.in Wed Jan 2 08:45:10 2002
-+++ config.h.in.new Thu Jan 3 07:06:23 2002
-@@ -163,6 +163,7 @@
- /* strerror_r works! */
- #undef HAVE_WORKING_STRERROR_R
-
-+#include <stdlib.h>
-
- #ifndef HAVE_STRCASECMP
- int strcasecmp (const char *a, const char *b);
diff --git a/mail/libesmtp/files/patch-ltmain.sh b/mail/libesmtp/files/patch-ltmain.sh
new file mode 100644
index 000000000000..98cb05e4ddb3
--- /dev/null
+++ b/mail/libesmtp/files/patch-ltmain.sh
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/libesmtp/files/patch-ntlm::ntlmstruct.c b/mail/libesmtp/files/patch-ntlm::ntlmstruct.c
new file mode 100644
index 000000000000..e08343316330
--- /dev/null
+++ b/mail/libesmtp/files/patch-ntlm::ntlmstruct.c
@@ -0,0 +1,14 @@
+--- ntlm/ntlmstruct.c.orig Tue Jan 29 13:05:13 2002
++++ ntlm/ntlmstruct.c Tue Jan 29 13:06:02 2002
+@@ -25,7 +25,11 @@
+ #include <config.h>
+ #endif
+
++#ifdef __FreeBSD__
++#include <inttypes.h>
++#else
+ #include <stdint.h>
++#endif
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
diff --git a/mail/libesmtp/pkg-plist b/mail/libesmtp/pkg-plist
index dcbacb816cf5..4352f2596ed9 100644
--- a/mail/libesmtp/pkg-plist
+++ b/mail/libesmtp/pkg-plist
@@ -6,6 +6,8 @@ lib/esmtp-plugins/sasl-cram-md5.a
lib/esmtp-plugins/sasl-cram-md5.so
lib/esmtp-plugins/sasl-login.a
lib/esmtp-plugins/sasl-login.so
+lib/esmtp-plugins/sasl-ntlm.a
+lib/esmtp-plugins/sasl-ntlm.so
lib/esmtp-plugins/sasl-plain.a
lib/esmtp-plugins/sasl-plain.so
lib/libesmtp.a