aboutsummaryrefslogtreecommitdiff
path: root/mail/libmapi/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
commit7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8 (patch)
tree2b6d3a0598b45365f230c6f61cf8d8d784b7016d /mail/libmapi/Makefile
parent6b610ab5e04c7e7c7916ffe651ed9b7824436bca (diff)
downloadports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.tar.gz
ports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.zip
Notes
Diffstat (limited to 'mail/libmapi/Makefile')
-rw-r--r--mail/libmapi/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/mail/libmapi/Makefile b/mail/libmapi/Makefile
index 2a1cbea650fc..5909ddfb329f 100644
--- a/mail/libmapi/Makefile
+++ b/mail/libmapi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libmapi
PORTVERSION= 2.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= https://github.com/openchange/openchange/archive/
DISTNAME= openchange-${PORTVERSION}-${CODENAME}
@@ -28,7 +28,7 @@ WRKSRC= ${WRKDIR}/openchange-openchange-${PORTVERSION}-${CODENAME}
USE_MYSQL= yes
USES= autoreconf:build bison compiler:c++11-lib gmake pathfix \
- pkgconfig python shebangfix sqlite
+ pkgconfig python samba:lib shebangfix sqlite
PATHFIX_MAKEFILEIN= Makefile
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -48,24 +48,18 @@ SHEBANG_FILES= libmapi/conf/mparse.pl \
OPTIONS_SUB= yes
OPTIONS_DEFINE= BOOST DOXYGEN
-# SAMBA43
OPTIONS_DEFAULT=BOOST
BOOST_LIB_DEPENDS= libboost_thread.so:devel/boost-libs
BOOST_CONFIGURE_ENV_OFF= ov_cv_boost_thread=no
BOOST_DESC= libmapi C++ library (needs boost)
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CONFIGURE_ENV_OFF= ac_cv_path_DOXYGEN=""
-SAMBA43_DESC= Build agains samba 4.3 instead of 4.2
+PLIST_SUB= SAMBA=${SAMBAPORT:T}
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-# no support for samba 4.3 yet
-.if ${PORT_OPTIONS:MSAMBA43}
-SAMBA_DEP= samba43>=4.3.0:net/samba43
-PLIST_SUB+= SAMBA=samba43
-.else
-SAMBA_DEP= samba42>=4.2.0:net/samba42
-PLIST_SUB+= SAMBA=samba42
+.if ${SAMBA_DEFAULT} == 4.4
+BROKEN= fails to build
.endif
# --enable-openchange-qt4 Compile OpenChange Qt4 wrapper.
@@ -89,4 +83,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/shared-modules/dcerpc_server/*.so
@${STRIP_CMD} ${STAGEDIR}/${PREFIX}/modules/dcerpc_mapiproxy*/*.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>