aboutsummaryrefslogtreecommitdiff
path: root/mail/libsieve
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-08-05 22:21:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-08-05 22:21:37 +0000
commit82e1beade1b7cd993e28e7f03af390e98dd48073 (patch)
tree004b897ae23d6b766b85e7976cd424985a0ab44b /mail/libsieve
parentac0bd8971432d2056af8150a554d5011f54e6181 (diff)
New port: mail/libsieve A library to interpret Sieve scripts, and
to execute them over a given set of messages A library for parsing, sorting and filtering your mail. libSieve provides a library to interpret Sieve scripts, and to execute those scripts over a given set of messages. The return codes from the libSieve functions let your program know how to handle the message, and then it's up to you to make it so. libSieve makes no attempt to have knowledge of how SMTP, IMAP, or anything else work; just how to parse and deal with a buffer full of emails. PR: ports/101346 Submitted by: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
Notes
Notes: svn path=/head/; revision=169778
Diffstat (limited to 'mail/libsieve')
-rw-r--r--mail/libsieve/Makefile26
-rw-r--r--mail/libsieve/distinfo3
-rw-r--r--mail/libsieve/pkg-descr8
-rw-r--r--mail/libsieve/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/mail/libsieve/Makefile b/mail/libsieve/Makefile
new file mode 100644
index 000000000000..8e2afff928cc
--- /dev/null
+++ b/mail/libsieve/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libsieve
+# Date created: 4 August 2006
+# Whom: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsieve
+PORTVERSION= 2.1.13
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libsieve
+
+MAINTAINER= mark_sf@kikg.ifmo.ru
+COMMENT= A library for parsing, sorting and filtering mail
+
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC=${WRKSRC}/src
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${WRKSRC}/src
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/mail/libsieve/distinfo b/mail/libsieve/distinfo
new file mode 100644
index 000000000000..06da73693cd6
--- /dev/null
+++ b/mail/libsieve/distinfo
@@ -0,0 +1,3 @@
+MD5 (libsieve-2.1.13.tar.gz) = 684fc3e9f52ce23c1fe31de8b05594f9
+SHA256 (libsieve-2.1.13.tar.gz) = 911776db256f8b6a3150629974232d7820613eeb65d88b6b5aca394586eae749
+SIZE (libsieve-2.1.13.tar.gz) = 793919
diff --git a/mail/libsieve/pkg-descr b/mail/libsieve/pkg-descr
new file mode 100644
index 000000000000..bc5a169a0abf
--- /dev/null
+++ b/mail/libsieve/pkg-descr
@@ -0,0 +1,8 @@
+libSieve provides a library to interpret Sieve scripts, and to execute those
+scripts over a given set of messages. The return codes from the libSieve
+functions let your program know how to handle the message, and then it's up to
+you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
+IMAP, or anything else work; just how to parse and deal with a buffer full of
+emails. The rest is up to you!
+
+WWW: http://libsieve.sourceforge.net/
diff --git a/mail/libsieve/pkg-plist b/mail/libsieve/pkg-plist
new file mode 100644
index 000000000000..954e47e766a8
--- /dev/null
+++ b/mail/libsieve/pkg-plist
@@ -0,0 +1,6 @@
+include/sieve2.h
+include/sieve2_error.h
+lib/libsieve.a
+lib/libsieve.la
+lib/libsieve.so
+lib/libsieve.so.1