aboutsummaryrefslogtreecommitdiff
path: root/mail/libvmime
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-03-08 18:54:06 +0000
committerXin LI <delphij@FreeBSD.org>2012-03-08 18:54:06 +0000
commitd0d0e0ba2369a2d625ad20f969ccdf53e33f96b9 (patch)
treed365302349a15a5b87e8962721616624056bf4a8 /mail/libvmime
parentfc0829d8ded3b6de200fa6357ee0433ed4e81b11 (diff)
downloadports-d0d0e0ba2369a2d625ad20f969ccdf53e33f96b9.tar.gz
ports-d0d0e0ba2369a2d625ad20f969ccdf53e33f96b9.zip
Notes
Diffstat (limited to 'mail/libvmime')
-rw-r--r--mail/libvmime/Makefile6
-rw-r--r--mail/libvmime/files/patch-src__mailboxField.cpp11
2 files changed, 14 insertions, 3 deletions
diff --git a/mail/libvmime/Makefile b/mail/libvmime/Makefile
index 44de20efe8bb..1ae9842063e2 100644
--- a/mail/libvmime/Makefile
+++ b/mail/libvmime/Makefile
@@ -7,15 +7,15 @@
PORTNAME= libvmime
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= SF/vmime/vmime/0.9
MAINTAINER= delphij@FreeBSD.org
COMMENT= An all-in-one Internet mail library
-LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
-LIB_DEPENDS+= gsasl.15:${PORTSDIR}/security/gsasl
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gsasl:${PORTSDIR}/security/gsasl
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/mail/libvmime/files/patch-src__mailboxField.cpp b/mail/libvmime/files/patch-src__mailboxField.cpp
new file mode 100644
index 000000000000..94d559aa5447
--- /dev/null
+++ b/mail/libvmime/files/patch-src__mailboxField.cpp
@@ -0,0 +1,11 @@
+--- ./src/mailboxField.cpp.orig 2009-09-06 05:10:27.000000000 -0700
++++ ./src/mailboxField.cpp 2012-03-08 10:49:05.687243933 -0800
+@@ -51,7 +51,7 @@
+ // Here, we cannot simply call "m_mailbox.parse()" because it
+ // may have more than one address specified (even if this field
+ // should contain only one). We are never too much careful...
+- ref <address> parsedAddress = address::parseNext(buffer, position, end, newPosition);
++ ref <address> parsedAddress = mailbox::parseNext(buffer, position, end, newPosition);
+
+ if (parsedAddress)
+ {